Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop (Sony Vaio E series), with an external monitor attached to it. By default, it puts the two screens in mirror. I don't like mirror mode for various reasons and want to change it (turn the laptop screen off and the external monitor on). However, whenever I go into the built in monitor configuration tool, take it off of mirror mode, turn the laptop screen off, and hit apply, both screens go black.

It worked fine in ubuntu 10.10, but not in ubuntu 11.04. Does anyone have any suggestions on how to fix this? Thank you.

Edit: As requested, this should show what video card I have:

$ lspci | grep 'VGA'
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Edit 2: Some more information:

$ xrandr -q
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1366x768       59.9 +
   1360x768       59.8     60.0  
   1024x768       60.0* 
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0 +   75.0  
   1024x768       75.1     70.1     60.0* 
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

Edit3: (Again, as requested by the comments)

I typed in:

xrandr --output LVDS1 --off

And the laptop screen turned off just fine, with no ill side effects (okay, my computer froze up once, but that may have been for another reason). Here is the results of running:

DISPLAY=:0.0 xrandr -q

-

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
   1366x768       59.9 +
   1360x768       59.8     60.0
   1024x768       60.0
   800x600        60.3     56.2
   640x480        59.9
VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0 +   75.0
   1024x768       75.1     70.1     60.0*
   832x624        74.6
   800x600        72.2     75.0     60.3     56.2
   640x480        72.8     75.0     66.7     60.0
   720x400        70.1
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

So this seems to be working (although the resolution on the VGA is still not at the (proffered) 1280x1024. Anyway, still thank you for your help so far.

share|improve this question
    
Could you update your question to include the output of xrandr -q when the external monitor is plugged in? –  James Henstridge Jul 26 '11 at 1:56
    
Alright, I've added both of those, thank you so far. –  Leif Andersen Jul 26 '11 at 4:04
    
If you want to try and isolate the problem to just what the X server is doing, try running xrandr --output LVDS1 --off. That should turn off the laptop panel while leaving the external display active. If that still results in both screens being turned off and you've got the ability to ssh into the machine, it would be interesting to see what the xrandr settings are like with DISPLAY=:0.0 xrandr -q. –  James Henstridge Jul 27 '11 at 1:35
add comment

2 Answers 2

up vote 0 down vote accepted

I've had a similar problem and I've found if you lower the resolution in the display settings and apply it before making any further changes you don't get black screens. You can then turn mirroring off and rearrange the monitors in the display settings. Once this is done you can reset the original resolution. I suspect the problem is somehow related to making multiple settings at once. This may not work for you but it's worth a try. :¬}

share|improve this answer
    
This also worked. –  Leif Andersen Oct 10 '11 at 19:56
add comment

Yeah this worked for me too. Turning the screen on again with a low res worked. I could then increase the res back to max:

xrandr --output LVDS1 --mode 800x600 (on !)
xrandr --output LVDS1 --mode 1024x600 (back to normal, phew)
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.