Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently Linus Torvalds announced the launch of next generation of the Linux Kernel: Linux 3.0. However, I have no idea how to update to this kernel version.

share|improve this question
7  
I really would recommend not to update. There are so many changes in the 3.0 version that it will sure break everything. Why not wait for Ubuntu 11.10. Having the latest does not mean it will be a good thing. –  Luis Alvarado Jul 25 '11 at 14:38
    
@CYREX While I don't recommend upgrading either, we should answer the question anyway. –  jrg Jul 25 '11 at 14:46
2  
So many changes? As far as I know, it's only the next iteration after 2.6.39. CYREX, do you have a source? –  user606723 Jul 25 '11 at 14:52
1  
@CYREX This is just a version rename, it contains a "large" update but it's nothing monumental. That being said you are correct that this will likely break things because there are changes. –  Marco Ceppi Jul 25 '11 at 15:31
    
So, kabindra, keep in mind. There is nothing extra-ordinary about the 3.0 kernel version. There is little reason to want to upgrade to it specifically. It's the same thing as 2.6.40.. if such a version existed. –  user606723 Jul 25 '11 at 15:45
show 2 more comments

2 Answers 2

I would like to echo @CYREX comment - you are already beyond the standard Natty configuration with the unstable Gnome 3 PPA. Adding v3 of the Kernel might make your system unusable.

To try a newer kernel download the following .deb files from the v3.0-oneiric mainline tree.

  1. headers_i386.deb or headers.amd64.deb depending if you are using 32bit or 64bit
  2. headers_all.deb
  3. image_i386.deb or image_amd64.deb depending if you are using 32bit or 64bit

Install via

cd ~/Downloads
sudo dpkg -i *.deb
sudo update-grub

Note the following from the kernel wiki -

Each mainline build is named by the base upstream version suffixed with an Ubuntu release name. This tells us the upstream version which was built, and additionally which configuration was used to build it. This tells us which release is most compatible with the kernel as built. This does not prevent the kernel being used on other releases, though it is most likely to work correctly on the release it is build for, or earlier ones. The further away from your base kernel release you are the more likely that there will be an incompatible userspace interaction which will prevent them working for you

share|improve this answer
1  
this is for oneiric release. this will definitely make system unstable. –  kabindra Jul 25 '11 at 15:28
1  
Ubuntu kernels are generally very close to the mainline builds. Usually the kernel team just name the folders with the distro name for what distro they are targetting their testing. I would be very surprised if there was any specific "oneiric" configs in the kernel. –  fossfreedom Jul 25 '11 at 15:37
    
Another reason to stay away from mainline builds: these are built with an older toolchain (from 8.04 Hardy) and therefore modules which are built on the system (i.e. dkms modules) cannot be unloaded. I don't know if this has other side-effects too, but this caused weird behavior when testing acpi_call on an Oneiric machine running the mainline 3.1 kernel. –  Lekensteyn Oct 11 '11 at 19:53
add comment

There are a number of changes to underlying systems like the boot process which have changed with Oneric, and simply upgrading the kernel on Natty does not work smoothly for me on my Natty machine. You need the module-init-tools - see https://launchpad.net/ubuntu/oneiric/amd64/module-init-tools/3.13-1ubuntu1 and possibly new versions of other tools (see http://awhitcroft.blogspot.com/2011/06/oh-no-30.html) I'd say it's best to stay with an earlier kernel for now in Natty. I've found that 2.6.39-020639rc4-generic fixed a number of minor but annoying problems (related to multi monitors and suspend) for me on my HP 5230m...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.