Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My old tft broke down. I have two actually. I had to replace the main one (originally I had 1980x1200 resolution) with one with 1980x1080. I fixed the resolution in the xorg.conf with the nvidia settings tool.

However unity/gnome doesn't seem to notice the resolution has changed?

Now my unity sidebar is only partially visible on the screen. How can I move it so it is fully visible again? I have not found any settings for that?

Update: Also on the login screen, the bar that would allow me to choose a non-unity classic session is not visible.

share|improve this question
    
I am pretty sure as the resolution X is running is correct. I fixed that. also see my comment below. but thanks for asking I tried to clarify my post. –  Yashima Jul 25 '11 at 13:01
    
Did you just replace one monitor with another? Have you tried the Monitors utility in System Settings to detect your monitor? If you are using a proprietary driver, like me, you may need to run the settings utility for that driver. In my case it is the NVIDIA X server Settings. It has a feature called X Server Display Configuration with a button to Detect Displays and another to Save to X Configuration file. This is what I would use if I was replacing one monitor with another. There may be a similar utility for your video display driver. Regards. –  grahammechanical Jul 25 '11 at 13:01
    
thanks for tryin to help. i have already run the nividia server settings and it has - after x-restart - recognized the monitor and the changed resolution. I also checked the xorg.conf that the resolution was correctly updated. X is correct. I am having trouble with unity -.- –  Yashima Jul 25 '11 at 13:04
    
yes very definitely. the monitor packaging says 1980x1080 and the nvidia settings tool and xorg.conf say the same. Another weird symptom I am experiencing is that the image of the screen is kind of fuzzy or blurred just as if the resolution really was wrong -.- –  Yashima Jul 25 '11 at 13:08
    
I made one and magically everything is there. I think I am an idiot. I am trying to figure out how to calibrate that monitor. Still the sharpness is another issue I'll have to figure out –  Yashima Jul 25 '11 at 13:21

1 Answer 1

up vote 1 down vote accepted

This sounds like a hardware issue - but some preliminary checks should be made:

  1. Double check the maximum resolution of the monitor via the box it came in/manual
  2. Check if using Nvidia graphics that both nvidia-settings and /etc/xorg.conf resolutions agree with the resolution you were expecting.
  3. Any other graphics cards, have a look at the "Monitor" window - both the monitor should be recognised and the correct resolution displayed.
  4. Double check cabling from the PC to the monitor - could be loose/faulty

Once you are satisfied with these checks - have a look at the Monitor itself.

Most monitors have a button(s) that you can change the position of the screen vertically and horizontally as well as the width and height.

For sharpness issues - look for a setting that says "Auto" or "Fine".

share|improve this answer
    
Thanks :D it turned out that I forgot to check the monitor calibration. I found it when you suggested making a screenshot. Since the screenshot was perfect it could only be the monitor. –  Yashima Jul 25 '11 at 14:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.