Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a Asus Pundit P6 with an iCore5 and a Radeon HD 6450. Starting Ubuntu 11.04 from a Live-USB-stick doesen't make any troube, but after installing 11.04 (64bit and 32bit, subquestion: what's better?) PC starts from HDD... Ubuntu-logo shows flickering .. intro-music plays but the Logo doesn't go away. What to do (remember I'm no Linux-pro!)?

share|improve this question

2 Answers 2

I had a similar problem with my HP p7-1080t, same proc, same card. Had to install the AMD Radeon Linux driver And that solved my problem. [ubuntu 11.04 64-bit]

share|improve this answer

You are asking two questions :

  1. For the first one should I install Ubuntu 32 or 64bit?

    This depends on your processor. 32 and 64 correspond to the size of information that the processor deals with. So if your processor can deal with 64bit strings it should be faster using Ubuntu 64bit version.

    To check the type of processor you have; type uname -m in a terminal. If the output is x86_64 use 64bit version, if not use the 32bit one. (you can do this from the live CD)

  2. Installing AMD's proprietary driver should fix your booting problem. As you don't have a graphical mode where you can do it we will have to do through the command line.

    To get to the command line try typing ctrl alt F1 once the computer seems to have booted. (If this doesn't work try to get to the command line through the recovery mode (One of the boot options)).

    Once you are in terminal login, then type sudo apt-get install module-assistant build-essential fakeroot dh-make debconf bzip2 wget

    Now you need to download the driver :wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-7-x86.x86_64.run

    Once the file finished downloading type chmod +x ati-driver-installer-11-7-x86.x86_64.run && sudo ./ati-driver-installer-11-7-x86.x86_64.run

    Enter your password and follow the instructions to install the driver.

    Finally type sudo aticonfig --initial -f to configure the driver.

Reboot (sudo reboot)and everything should be mended.

Ps. I haven't tried everything I just wrote, I have already successfully installed AMD's driver from a terminal, hope it will work for you, good luck.

share|improve this answer
    
I did exatcly what danjjl did, but with new version of the driver. wget www2.ati.com/drivers/linux/… And worked perfectly for me! Thanks my friends! I'm using ubuntu 12.04! –  Guilherme Franco Jul 13 '12 at 14:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.