Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am currently suffering from a video card related bug (S-video output doesn't work in Natty) which causes my TV screen to flicker every 10 seconds. According to a Launchpad contributor, this is probably caused by the system running a regular xrandr probe.

Is there any way to safely disable this probe while I wait for a bugfix?

I want to be able to:

  • run my machine as normal when the S-video cable is not plugged in
  • plug in the cable and choose to output to the TV using the Monitor Preferences tool
  • unplug the cable and switch back to normal resolution
  • (low priority) boot up with the cable plugged in and have it be detected and used
  • not mess everything up

Is this possible? A system setting would be preferable, but a script/command to run after I've got the TV hooked up is acceptable.

share|improve this question

closed as off topic by fossfreedom Apr 2 '12 at 22:54

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
in that bug report one contributor mentioned installing kernel 2.6.34 and booting from that. Suggest investigate that route (download from herehttp://kernel.ubuntu.com/~kernel-ppa/mainline/ ) –  fossfreedom Jul 25 '11 at 8:47
    
that didn't work for me, so I'd prefer a solution on top of the current system, but thanks for the suggestion, it may work for someone else –  d3vid Jul 25 '11 at 9:31
    
possibly useful documentation: live.gnome.org/RandR (see bits about gnome-settings-daemon) –  d3vid Jul 26 '11 at 8:50
    
asked on an X.Org forum phoronix.com/forums/… –  d3vid Jul 28 '11 at 5:12
    
Since you have filed as a bug report - as such is off-topic, thanks! –  fossfreedom Apr 2 '12 at 22:54

Browse other questions tagged or ask your own question.