Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 11.04 and I works perfect.

I do not know what happened but for no reason the logout, restart and shutdown options disappeared from power menu.

I did restart it more than one time maybe it will solve the problem. also, I did all the updates and still the same thing.

I check the gconf-editor on /apps/indicator-session, all the options of suppress_* is not checked.

I've also tried purging the session indicator packages before reinstalling them:

sudo apt-get purge indicator-session indicator-applet-session
sudo apt-get install indicator-session indicator-applet-session ubuntu-desktop

I do not know when this problem happened but 2 weeks ago was every thing fine.

share|improve this question
    
This is not really a solution to your problem, but as a workaround in the meantime you can open a terminal (Ctrl+Alt+T) and type sudo reboot for a restart and sudo shutdown now -P for a shutdown. You might also see options come up when you press your machine's power button. –  WarriorIng64 Jul 25 '11 at 6:03
    
that what I do but I want to have it in the power menu –  user8580 Jul 25 '11 at 6:29
1  
Does your account have administrator rights? Is it included in the shutdown and halt groups? refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/… –  dmityugov Jul 25 '11 at 13:24
    
I dont get what you mean. –  user8580 Jul 26 '11 at 18:25
    
Try adding a new user, logging out and logging back in as that new user. If you can see the reboot/shutdown options, then it's an issue with your settings. If you can't figure out what the issue is, try migrating your files to that new user account you just created. –  bafromca Jul 29 '11 at 13:28

1 Answer 1

There is an existing bug report for this problem but it has not been updated or fixed.

It may be worth temporarily moving ~/.config/dconf/user to ~/.config/dconf/user.old and rebooting to see it that makes a difference as it may be due to something being locked down.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.