Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i have lenovo thinkpad x201 tablet with ubuntu 11.04. when i run mathematica or stress, the laptop overheats and shuts down. i loose all my work.

I would think that turbo boost (for intel i7) turns on and doesn't turn off when the temperature is too hot. anyway to manage that?

share|improve this question
1  
which version of ubuntu are you using? –  fossfreedom Jul 24 '11 at 21:05
    
i edited the post. 11.04 –  kirill_igum Jul 24 '11 at 21:12

1 Answer 1

There is a bug-report on launchpad which fits your tablet/laptop observation problem.

Reading through this, there are several suggestions, for example

  • In your BIOS - make sure you are using the latest BIOS version (see the Vendor website for any updates
  • Also in your BIOS - look for "Advanced Thermal Management" - Set this to "Balanced" rather than "Maximum"
  • Look at installing the package "thinkfan" from the repositories - NOTE THE WARNING IN THE BUG REPORT - read the documentation first, as incorrect usage can cause serious damage
  • Take a close look at your fans - clean out any dust etc
share|improve this answer
    
may I know why the Thermal Management setting should be set to Balanced instead of Maximum? My ThinkPad is overheating too, and incidentally my setting is set to Maximum. Thank you. –  onvas Aug 28 '12 at 6:22
    
balanced is the automatic setting used on battery - maximum is for AC. Thus forcing "balanced" makes the laptop use battery defaults which basically slows various settings to reduce power - and therefore prevents overheating –  fossfreedom Aug 30 '12 at 22:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.