Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am simply trying to upload photos to various online services. I am unable to upload files to the following services:

Gmail (as attachment) Picasa Web Albums (via Shotwell, Picasa, F-Spot, GoogleCL, or browsers Chrome/FF) Facebook (via Shotwell, F-spot, or browsers Chrome/FF) Dropbox etc.

Basically I can't upload anything

In all cases of browser based attempts I can can attach/queue files, but then there is no data going out. For apps such as Shotwell, I can log in to services, but files never upload and eventually timeout saying the remote service cannot be reached.

I have tried via WiFI and Wired connection, via the same O2 broadband router. Other machines (Windows, OSX) on the same network can upload files without a problem. I have not tried via a different broadband connection yet as I don't currently have access to one.

My setup:

  • Samsung N220 w/ Realtek 8192E wireless controller using ndiswrapper
  • Ubuntu 10.10 Maverick, all packages up to date

Happy to provide any further information, logs, etc. or anything that will help with troubleshooting. I consider myself a reasonably technical person and this problem is doing my head in!

share|improve this question
    
Update: This may no longer be purely an issue with my Ubuntu install, but possibly related to the router I have (from O2 broadband)... I have tried uploading through my Android phone's Wireless tether and it works fine :-( –  Streetdaddy Jul 24 '11 at 16:18

1 Answer 1

I don't think the problem is in the network, or you shouldn't be able to browse or send anything (and when you send an e-mail, you're already sending data, even without attachments).

Most of the upload tools use java applets, are you sure it's installed in your system? Or maybe it's installed but disabled?

put this in firefox:

about:addons

and in the plugins section look you have java enabled (icedtea in my case) If it's enabled you could try to reinstall it. The name of the package is:

icedtea-plugin

If it's a new install, maybe you haven't installed the restricted extras like flash and java, you could install'em with

sudo apt-get install ubuntu-restricted-extras

Good luck.

share|improve this answer
    
Thanks. I have check that both Java (via icedtea) and Flash are the latest version. However this doesn't explain why even native apps can't upload any files to any of these services. Even GoogleCL, a commandline python tool, is unable to send files to my Picasa Web Albums! Even in Gmail, I'm unable to send an email with even a single attachment. Nor can I upload a file via a simple HTML upload field... –  Streetdaddy Jul 24 '11 at 15:57
    
Nor can I upload a file via a simple HTML upload field, any file I try to upload (in Chrome) results in the 'Uploading 3%...' message in the bottom right corner of the browser and it never gets past that, eventually times out... –  Streetdaddy Jul 24 '11 at 16:02
    
Also @darent I have check Java in both Chrome and FF via this tool: javatester.org/enabled.html - both report Java is enabled. –  Streetdaddy Jul 24 '11 at 16:04
    
Shotwell and F-Spot do not use Java, so it's definitely not a Java problem. –  MrEricSir Jul 25 '11 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.