Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

From a script, I'm trying to apply some color levels to a grayscale .tiff image
(the same as I would do in Gimp).

I've tried using ImageMagick's convert tool:

convert input.tiff -level 102,200,0.85 output.tiff

and also

convert input.tiff -level 102,0.85,200 output.tiff

but all I get is a blank image.
Any ideas?? Are there other ways around?

share|improve this question
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  fossfreedom Mar 10 '12 at 7:23
add comment

1 Answer 1

The .tiff format is not well supported in ImageMagick according to the support documentation for the program so it is unlikely to work as expected, try any other supported image format and you should be able to achieve the results you want.

The TIFF format is the propriety format for PhotoShop. However it is so bloated with features, and has been modified by just about every application that has cared to use it, that no program, not even photoshop can handle ALL its variations. Photoshop however has the best chance at reading it.

I would steer clear of the TIFF image file format unless you are
specifically working with photoshop, or the application accepts no other, better defined, image file format.

I don't use the TIFF image file format, or Photoshop. If you use this format with IM extensively, perhaps you would like to submit your findings to me, to include here. That way you can help your fellow TIFF users.

Whether a specific software package can read a TIFF, all you can do is try it and see. That is the problem with this format.

share|improve this answer
    
Curiously, if I first adjust the levels (via -levels) and then separately adjust the gamma (via -gamma), it works... I'll try using a different format. –  jmendeth Apr 3 '12 at 12:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.