Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Kubuntu 11.04 on a machine, it's a completely fresh install. My network is called "linksys" (don't blame me, someone else set it up), and I know for a fact it is secured by WPA2 Personal. I am in fact connected to it on a different machine (also running Kubuntu 11.04) on the same network as I type this right now.

I also know the network card works with this OS. I just had a different install of Kubuntu 11.04 on it before, just reformatted and installed fresh. It was working fine on the old install.

Here's what's happening. When I go to add a wireless network connection, and type "linksys" as the wireless SSID, then go to the wireless security tab, the dropdown for "Security" contains only the option "None". If I type in any other SSID, the Security dropdown is normal (containing options like WEP, WPA/WPA2 Personal, etc...). So it seems it is only not letting me select a security method for my network, "linksys". Almost like it has decided for some reason it is definitely not a secured network.

But it is. If I try to connect to it without selecting a security, it simply fails. And, as I said, I am connected to it right now on a different computer with the same OS using WPA2 Personal.

Any reason why this might be happening?

share|improve this question
up vote 1 down vote accepted

Strange issue, I have no clue about it.

Maybe you should consider updating your fresh installed Kubuntu to fix any bugs

sudo apt-get update
sudo apt-get upgrade

I also recommend using Wicd instead of the default network manager, it is much better with more options and features.

Simply install wicd from the konsole:

sudo apt-get update
sudo apt-get install wicd

Then restart and run it, and give it a try, most probably it will work.

Last, you might need to disable the default network manager of KDE, or just uninstall it.

sudo apt-get remove network-manager

And don't forget to add wicd to your autostart list

Good luck !

share|improve this answer
So I installed wicd, and by looking at the list of networks there, I figured out the problem. It turns out there are two networks in my vicinity named "linksys" (again, blame the person that set up my network on this, not me). And network-manager by default only shows the one with the highest signal strength. Someone nextdoor just set up a "linksys" network. Anyway, you can override this by entering the BSSID (usually the WAP's MAC address) in the SSID field. Or by moving your computer closer to the access point. – Ben Lee Jul 25 '11 at 3:02
And FYI, wicd was not able to connect to the network either. Looks like even though it showed both "linksys" networks in the list, it also only tried to connect to the first one, which in this case was the unsecured one. I eventually solved this by uninstalling wicd again, using the regular network manager, and moving my laptop over by my router when setting up the network. After the network is set up and stored in network-manager, it always reconnects to the right one. – Ben Lee Jul 25 '11 at 3:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.