Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Wifi on my new Thinkpad W520 running Natty keeps dropping out and coming back on. Output from dmesg below. Any advice?

[30493.687552] wlan0: authenticate with e0:91:f5:ef:7b:b2 (try 1)
[30493.689127] wlan0: authenticated
[30493.689144] wlan0: associate with e0:91:f5:ef:7b:b2 (try 1)
[30493.693592] wlan0: RX AssocResp from e0:91:f5:ef:7b:b2 (capab=0x411 status=0 aid=4)
[30493.693595] wlan0: associated
[31631.172868] wlan0: deauthenticated from e0:91:f5:ef:7b:b2 (Reason: 7)
[31631.211847] cfg80211: All devices are disconnected, going to restore regulatory settings
[31631.211868] cfg80211: Restoring regulatory settings
[31631.211873] cfg80211: Calling CRDA to update world regulatory domain
[31631.215037] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
[31631.215042] cfg80211: World regulatory domain updated:
[31631.215044] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[31631.215046] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[31631.215049] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[31631.215051] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[31631.215053] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[31631.215055] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[31632.289638] wlan0: authenticate with e0:91:f5:ef:7b:b2 (try 1)
[31632.291262] wlan0: authenticated
[31632.291276] wlan0: associate with e0:91:f5:ef:7b:b2 (try 1)
[31632.295119] wlan0: RX AssocResp from e0:91:f5:ef:7b:b2 (capab=0x411 status=0 aid=4)
[31632.295123] wlan0: associated
[31886.234836] wlan0: deauthenticated from e0:91:f5:ef:7b:b2 (Reason: 7)
[31886.306735] cfg80211: All devices are disconnected, going to restore regulatory settings
[31886.306740] cfg80211: Restoring regulatory settings
[31886.306744] cfg80211: Calling CRDA to update world regulatory domain
share|improve this question
    
same problem here. –  BigSack Oct 1 '12 at 10:13
add comment

4 Answers

up vote 2 down vote accepted

I had this problem with Maverick so I installed the package linux-backports-modules-wireless-maverick-generic and I got a very stable system. (This packaged provided more recent wireless kernel modules than the default kernel.)

For Natty there is no package linux-backports-modules-wireless-natty-generic. - But you can try to install linux-backports-modules-cw-2.6.39-natty-generic and maybe your disconnects will go away. :)

share|improve this answer
add comment

I too had this problem. It was solved by installing WICD. Then uninstalling network manager. Then add WICD to your startup applications. Then reboot (essential). For me on a number of installations this has partially solved the problem

share|improve this answer
    
+1. Why was this down-voted? –  Geoff Apr 3 '12 at 13:36
    
I'm currently using wicd on Gentoo and just get this error on my home wifi access point. I think that's driver related. –  Spidey May 18 '12 at 3:03
add comment

It is driver related problem, please post result of "iw reg get" and "iw phy phy0 info"

share|improve this answer
add comment

I managed to fix this by compiling the driver from source after downloading it from the Realtek site - http://www.realtek.com/downloads/ - and searched for my wireless card on the field on the left.

So, to summarize: fixing this required two steps:

  1. Install WICD.
  2. Compile the original driver from source.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.