Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run baudline, it displays the message "all input devices disabled" and the Input ▸ Devices screen doesn't list any devices. The baudline FAQ suggests:

Here are two possible explanations for this:

  1. You don't have a properly configured audio card.
  2. Or you don't have read and write privileges for /dev/audio or /dev/mixer.

The observation that sound works in every other program I've tried (though there is one exception) strongly suggests that my sound card is properly configured.

The problem appears to be related to /dev/audio and /dev/mixer. I'm certain that I do not have read and write privileges for them, because they don't even exist. I think this bug report is responsible for their absence, but I'm not sure what it means for me.

I have used baudline in Ubuntu in past years without any problems. How can I make Ubuntu's sound configuration compatible with baudline again?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

My fix was to run it like this

parec --format=s16le --channels=1 --latency-msec=5 | ./baudline -stdin

This uses parec to read from pulseaudio and pipes it to baudline.

share|improve this answer
    
Of course! I should have thought of this. –  ændrük Apr 7 '12 at 21:25

Perhaps possible three choices:

  • See if the PulseAudio OSS Wrapper works with baudline e.g.

    padsp baudline -stdout > file.raw

  • Install a dual boot with ArchLinux

reading through the baudline FAQ is makes it mentions working with ALSA with OSS support. I would read that as needing a kernel with OSS support. Canonical removed this support from maverick and natty. Arch still has OSS support built into their linux kernel (I think)

  • compile your own kernel with the OSS flags (the flags in the bug report) with instructions such as in howtogeek
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.