Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I add in virtualbox 2 interfaces like bridge, Internal network 192.168.. and external 195...*

Internal config:

auto eth0
iface eth0 inet static
address 192.168.*.250
netmask 255.255.255.0
network 192.168.*.0
broadcast 192.168.*.255
gateway 192.168.*.254

External config:

auto eth1
iface eth1 inet static
address 195.*.*.182
netmask 195.*.255.248
network 195.*.*.176
broadcast 195.*.*.183
gateway 195.*.*.177

Now if i restart the networking eth0 successfull is up, but eth1 make the error:

root@Tudor-LX:/home/theo# /etc/init.d/networking restart
 * Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
 * Reconfiguring network interfaces... 
SIOCSIIFADDR: No such device
eth1: ERROR while getting interface flags: No such device 
SOICSIFNETMASK: No such device 
SIOCSIFBRDADDR: No such device 
eth1: Error while getting interface flags: No such device 
eth1: Error while getting interface flags: No such device 
Failed to bring up eth1. 
ssh stop/waiting 
ssh start/running, process 1260
share|improve this question
    
Does eth1 exist on your host machine? (assuming that external is your host) –  Lekensteyn Jul 25 '11 at 9:17

2 Answers 2

Run this...

Do not run this in a root shell, just run it using sudo. I've seen the SIO errors the first time you run the command, but not the second time. You may have to run it twice in a row.

I would also comment out the auto eth statements.

share|improve this answer
1  
auto eth* makes ifup -a bring up these interfaces. Why should it be disabled? –  Lekensteyn Jul 24 '11 at 21:05
    
auto eth is for DHCP. You've configured these for static and DHCP at the same time. That's probably the source of the problem. –  Aric Jul 25 '11 at 0:31
2  
no, auto eth0 does not enable DHCP, for that you need to put in iface eth0 inet dhcp which is not desired here. Please read to the manual page interfaces(5). –  Lekensteyn Jul 25 '11 at 9:13
    
I stand corrected; you are right. Okay, so if you do an ifconfig, what is the output? Is eth1 listed? Is the link up? –  Aric Jul 26 '11 at 2:54

I believe saying that auto eth is for DHCP only is WRONG!

The auto = just means to: Automatically Launch The Ethernet Device Listed!

I Setup Mines Similar! Maybe this can help!

Using AUTO & STATIC IP!:

auto eth0
iface eth0 inet static
        address 192.168.x.x
        netmask 255.255.255.0

#########

    auto eth0:1
    iface eth0:1 inet static
    address 192.168.x.x
    netmask 255.255.255.0
    gateway 192.168.0.1
    dns-nameservers 8.8.8.8 8.8.4.4

Both Host & eth0:1 - Have There Own Static IP!

With eth1. I will receive the same error!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.