Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop with a Nvidia G105M, the main monitor has a 1366x768 resolution and I am trying to configure an external monitor to become independent from the main monitor (laptop screen).

With Twinview I expand the workspaces, which every time i change to another workspace it happens in both monitors and that's not what I need, I only need the external monitor for VirtualBox, mupen64plus and VLC.

I can't use the Monitor Settings as it always says unknown in the monitor image. So I use the Nvidia Settings, where in the monitor configuration area I click Detect and the 2nd Monitor appears as Disabled and now I can configure the 2nd Monitor in Twinview or Separate X Screen. However when I use Twinview the second Monitor IS an extension from the 1st Monitor which means that when I switch Workspaces, it switches in both monitors. What I want is to have the 2nd monitor to NEVER change workspaces so that I can always see the same window in it, be it VirtualBox, VLC or Terminator

I looked around the forums and the questions here but didn't find anything that related to my situation.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

This is possible with the nvidia-settings application that comes with the NVIDIA driver, so make sure that one is installed by typing jockey in the dash to start the extra drivers application.

Make sure to start nvidia-settings as root so it can save the configuration for you, this can be done by pressing alt+f2 and typing gksudo nvidia-settings. Once started, select the X Server Display Configuration category (1), select your external monitor and choose Seperate X screen (2) as configuration. Click Save to X Configuration File (3) to save these settings to your xorg.conf. Log out and back in to apply these changes. nvidia-settings

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.