Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Last week i tried to install Ubuntu 11.04 and i have a problem i cannot solve.

Mit Grafics Card is an Nvidia 9500GS which worked well with Ubuntu, Compiz and stuff before.

The Problem:

  • i installed Ubuntu 11.04 from the life cd besides an Windows 7 Home Premium
  • When i boot up ubuntu everything seems to be right
  • The logon screen appears
  • When i log in the screen is black in an interval of less then a second i can see the gui elements (panels, desktop icons etc.. flickering).
  • The only way i can shutdown the system now is doing it the hardware-way

What i tryied so far (1. Attemp):

  • i logged into the Safe-Mode which works well
  • i tryied to install the nvidia properitary drivers through the gui this does not work saying "Can't find a valid source for the driver"
  • i activated the nvidia driver through the console with jockey which worked. In the gui there was the green dot then
  • rebooting, trying to log in again Same Problem

What i tryied so far (2. Attemp):

  • so i rembered that in some versions of ubuntu in the past i had to install fresh nvidia drivers downloaded from their website.
  • i downloaded the drivers from nvidia
  • tryied to start them (unfortunately the installation process requires to switch off X Server) which i tried by the way i knew (sudo /etc/init.d/gdm stop). Which tells me "Use sudo service gdm stop" or something similar. I tried that without success.
  • Then i tried to switch to a console without gui by hitting "strg+alt+f1" but this results in eternal black. I can then switch back to the gui through "strg+alt+f7".

So the problem with my second attemp is, that i can't get a console without a gui and i can't install nvidia drivers with the gui ant i can't shutdown the gui while being in the gui (spooky)...

So do you have any ideas, what i did wrong or what i could try to get this fixed again? Maybe its not a Graphics Problem at all and you know better?

share|improve this question
    
    
Mhm... thanks four the links. But in know everything in there. This does not solve my problem or even adresses it. My Problem is before installing Nvidia software. –  Chris Jul 20 '11 at 16:56
    
I see. what happens when you do sudo service gdm stop? –  user606723 Jul 20 '11 at 17:39
add comment

marked as duplicate by Luis Alvarado Apr 20 '13 at 1:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

try to install latest driver

sudo apt-get install nvidia-glx-185

If you getting any problem after install then log with recovery mode[2nd option of grub menu] go to root shell.

sudo apt-get autoremove nvidia-glx-185
share|improve this answer
    
thanks for your help, i got this to work yesterday afternoon before i read this answer here so i didn't try this. –  Chris Jul 21 '11 at 11:43
add comment

Thanks for all the information. i couldn't get the service to stop and also no console windows without gui, but i solved the main problem. For some reason i had to make all updates in the safe mode. After that, i was able to install the NVidia driver through the jockey-gui successfully.

Now i habe a nice 11.04 installation with unitiy and everything working nice.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.