Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a problem with my Ubuntu and my subwoofer. It won't work until I go into sound preferences -> output tab and re-select the device. Two devices are displayed: 1: Internal Audio analog surround 5.1 (this is the one I have to use) 2: HDA NVidia Digital Stera (HDMI)

The problem is that this isn't something I have to do just once after boot. No, I have to do this everytime I want to listen to anything. IE: Whenever Rythmbox changes songs, the new song will not play through the subwoofer. I have to change the prefence on every single song. OR, whenever I watch a video, or open youtube, or do anything. And it's not really just the subwoofer. It's bass in general.

Basically, I can't even listen to music anymore because I always always always always have to re-set the sound preference on every song.

Now, I never had a problem before until I added a bluetooth adapter (dongle?) to my computer. After the drivers installed for that, my sound preferences won't work.

Why won't it just always work?

Please help if you can. Thanks.

share|improve this question
    
What is your sound card setup? –  topless Jul 20 '11 at 1:06
    
I'm using the sound on my motherboard. A Gigabyte P55M-UD4 3 outputs to the sound system which is 5.1 speaker set. –  kitecraft Jul 20 '11 at 1:24
    
what lspci | grep audio gives? –  topless Jul 20 '11 at 1:25
    
lspci | grep Audio 00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05) 01:00.1 Audio device: nVidia Corporation Device 0e09 (rev a1) –  kitecraft Jul 20 '11 at 1:27

1 Answer 1

up vote 5 down vote accepted

This is just a guess, but in /etc/pulse/daemon.conf set enable-lfe-remixing: no to yes and make sure it is not commented (has no semicolon in front of it). If you made changes, save them and restart your system (or just pulseaudio).

share|improve this answer
    
That was a very good guess then. I un-commented the line and changed it to yes and it worked. Thank you very much. Cheers –  kitecraft Jul 20 '11 at 13:14
    
Glad it worked. How about an upvote and marking the question as answered? –  con-f-use Jul 20 '11 at 16:34
    
< embarrassed > I can't seem to figure out how to mark it as answered. <later> Oh, think I got it but I'm not a member so can't upvote. –  kitecraft Jul 20 '11 at 22:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.