Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've a USB bluetooth dongle

root@maiko-cce-lin:~# lsusb | grep Bluetooth
Bus 001 Device 007: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

that isn't working properly, hardly-ever it works but stops working in my next reboot.

what I've tried

it isn't software blocked

root@maiko-cce-lin:~# rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

my device is recognized by hciconfig

root@maiko-cce-lin:~# hciconfig -a
hci0:   Type: BR/EDR  Bus: USB
    BD Address: 00:1F:81:00:01:1C  ACL MTU: 1021:4  SCO MTU: 180:1
    DOWN 
    RX bytes:330 acl:0 sco:0 events:8 errors:0
    TX bytes:24 acl:0 sco:0 commands:30 errors:22
    Features: 0xff 0x3e 0x09 0x76 0x80 0x01 0x00 0x80
    Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
    Link policy: 
    Link mode: SLAVE ACCEPT 

but I can't turn on my hci interface

root@maiko-cce-lin:~# hciconfig hci up
Can't init device hci0: Connection timed out (110)

I don't understand why.. the hcitool command doesn't show any device.

root@maiko-cce-lin:~# hcitool dev
Devices:

I've tried to restart my bluetooth service too with this command and make all these previous commands again but without success.

root@maiko-cce-lin:~# service bluetooth restart
 * Stopping bluetooth                                                    [ OK ] 
 * Starting bluetooth                                                    [ OK ] 
root@maiko-cce-lin:~# 

The dongle works if you disconnect it from usb, wait a few seconds and connect it again. so there must be better solution for it ( a solution not involving physically removing the dongle!)

share|improve this question

closed as too localized by Bruno Pereira Mar 4 '12 at 10:10

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Hello, this question has no information and activity for a very long time. I am closing it for now. If by any reason you think this question is still viable or useful in anyways or that there is still a good chance it will be answered please flag it to a moderator or add a comment with the reasons why you want it open. Regards –  Bruno Pereira Mar 4 '12 at 10:10
    
This question has come up again. I think it is relevant now. –  Whaaaaaat Oct 29 at 8:22

Browse other questions tagged or ask your own question.