Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I encounter grave problems trying to print PDF-files, no matter whether I use Evince, Okular or any other linux program. The Documents are printed extremely slowly or even completely fail to print at all. I have tried printing from various Ubuntu-Installations on different network-printers (canon and lexmark), with the same result. On the other hand the same files are printed swiftly through Windows, which is a pity, since I do not want to use Windows.

Are there any solutions?

Thanks in advance!

share|improve this question
    
Is it just network printing? Can you print to a locally printer via xpdf - i.e. using LPR not CUPS. Possibly this old bug is still occurring - bugs.launchpad.net/ubuntu/+source/poppler/+bug/382379 –  fossfreedom Jul 24 '11 at 16:58
    
Printing pdf-files locally works but not at the speed it does under Windows. Is there a way to fix the problem? –  YSN Jul 25 '11 at 20:15
add comment

2 Answers 2

up vote 2 down vote accepted
+50

Here are a few suggestions to try:

  • use xpdf: i.e. xpdf <document name> should automatically direct to your default printer
  • if its a laser printer try adding a printer with using "Generic" as the manufacturer, and "Generic PCL5e printer" as the model i.e. most lasers support PCL.
  • When printing - print to a file - give it a name and print to a .ps file. Then open up the .ps file. It should reopen in evince. This time print it again to your printer.

source

share|improve this answer
    
Thanks for your suggestions! I will try them out asap! –  YSN Jul 25 '11 at 21:03
    
Great, the "Generic PCL5e" driver works for me. Thank you so much! Cheers –  YSN Jul 26 '11 at 9:40
    
Don't try this with a Brother network laser printer. –  Pointy Dec 4 '13 at 18:32
add comment

Just for people to who it would also happen: I had the same problem, and in my case the solution was also to change the driver: more precisely change my footmatic/pxl color driver to the footmatic/postscript equivalent.

My printer was a Sharp MX-2300N, and the "Generic PCL5e printer" only enabled to print in grey scale, so I really had to stay on the manufacturer drivers.

Well, actually I have no idea why it worked, I just did it because an other printer on the network had also a postscript driver and was working perfectly well...

What's actually the difference between postscript and pxl drivers?

share|improve this answer
    
Funnily enough, this page: link is proposing exactly the opposite solution to what worked with me... –  Julien Gorenflot Jun 19 '12 at 10:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.