Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

weird screen

I got this after upgrading to 11.04 with some issues. It must be tty7, since Ctrl+Alt+7 does nothing. I can change to tty[0-6] to make the screen look normal, and changing back makes the screen black.

What is happening here? It's like it thinks I have X installed.

Thanks.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Temporarily edit your grub boot settting: remove vga=something and replace it with nomodeset. If you can boot normally to the desktop, do your troubleshooting and perhaps install/uninstall proprietary graphics driver or maybe remove any unsuitable graphics option.

share|improve this answer
    
No desktop, no graphics drivers, no X. This is (most of the time) a headless server ;-) But I will try nomodereset. –  Znarkus Jul 20 '11 at 18:12
    
The kernel now has KMS (kernel mode setting), that uses the in-kernel graphics drivers to attempt to initialise any discovered graphics hardware. If your device has a graphics adaptor (likely, as you've attached it to the monitor), the kernel will try to do something (although it may not select the optimal driver, or may be hopelessly confused). –  Emmet Hikory Jul 21 '11 at 2:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.