Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been through all questions with the 'Shutdown' tag on this site - but this is different.

I choose "Shutdown..." from the session menu. I then click "Shutdown" on the dialog that appears.

Sometimes this does give me a shutdown and sometimes nothing happens and I am left with my desktop - which still works fine (that is, I can continue working on my computer if I want). Typing "sudo halt" from a terminal always works.

I'd like to have shutdown work every time. Can anyone help?

share|improve this question
    
which version of Ubuntu are you using? 11.04? Do you have any network shares mounted? I just had this problem today with Kubuntu 12.04. –  MountainX Apr 17 '12 at 16:22
add comment

4 Answers 4

you can try experimenting with different kernel options. try one at a time and see if it has any effect

like for example:

acpi = force or acpi = off

to try one out , when grub(with the selection screen of ubuntu-linux kernels, pops up after you have booted your computer,

press the "e" button to edit your current configuration.
to the line that has the words single quiet, add one of the proposed otions above.

this setting is not permanent over reboot so there is no risk of wrecking anything. if this works, and you want to make it permanent its time for a follow up question :)

share|improve this answer
add comment

You may also track if there's not a program preventing you from shutting down.

For example, I use a messaging client on my pc (QNetSoul, only for my school), and when I click on the shutdown button for the first time, it will only daemonize the program. Then my computer will not shutdown, even if I wait for an hour. But if I try it a second time, it finally kills it and effectively shutdown.

In your situation, does a second click on the shutdown button turns your computer off? Or is it really prevented from shutting down until you do a sudo halt?

share|improve this answer
add comment

Do a wright click on your session menu bar. Then there is a possibility to add something to this panel. So add the shutdown button who does appears. This always work. I had the same problem and now i use this button.

share|improve this answer
    
I can't do this because I'm using 11.04 with Unity. But I used your idea and now use gshutdown to shutdown 1 minute from now. Not fantastic, but it works. Thanks Julien. –  Jarlath Jul 19 '11 at 23:30
add comment

You have basically messed around with the settings and this WILL fix but all you need to do is go into settings and try and fix what you have done!

share|improve this answer
    
Hi Hayley and welcome to Ask Ubuntu. Your answer is not very helpful. If you know how to fix the problem, you need to include a step-by-step tutorial on how to fix it or not answer it at all. If it does not answer the question, it is not an answer. You may consider adding this as a comment instead or editing your answer to be more relevant and helpful. Make sure to read our FAQ. Hope you have a nice time here on Ask Ubuntu, and don't forget to hold off on the unnecessary bold! ;) –  Mochan Dec 23 '12 at 2:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.