Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just can't seem to get the .net 2.0 Framework installed using wine / winetricks.

I typed

winetricks

into the terminal, selected dotnet20sp2, and proceeded to install it.

Unfortunately, I can't get it to work. After accepting the license agreement, it says "Installing" for about 5 seconds, and then reports:

Setup Error

(Yes, that's all it says. Silly Microsoft!)

How should I go about installing it.

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

This looks quite a bit like the winetricks bug 70. The issue reports the root cause being in a wine bug, but I didn't go in to more detail in my investigations. If this is indeed the case, you might want to add additional information there and follow the bug for new changes in the bug status.

share|improve this answer
add comment

Have you considered using Mono? http://www.mono-project.com/

share|improve this answer
2  
No. Mono doesn't have the WPF. –  Nathan Osman Aug 1 '10 at 0:24
2  
.NET 2.0 doesn't have WPF - it was introduced in .NET 3.0. Mono fully suports .NET 2.0 API. –  Rodrigo Carvalho Aug 1 '10 at 12:47
1  
And wine doesn't support .NET 3.0. If you need to use WPF in linux you are out of luck. –  Javier Rivera Aug 11 '10 at 11:33
add comment

Try PlayOnLinux to install .net 2.0 over Ubuntu. It may help you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.