Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have opened up this question on launchpad too, but in the interest of getting a bigger response base I am posting it here, hoping someone will pick it up.

Natty doesn't behave very well with the Intel 82845GL chipset. I booted my old machine with Natty today to test drive it. The specs are:

Processor: Celeron 2.4GHz Video: Intel 845GL RAM: 1GB

The first problem is that the display is borked! What do I mean? Well, see for yourself:

enter image description here

If that gets fixed (and it did for a while but is back now), Unity is disabled.

I think these issues are owed to hardware acceleration being disabled...or in other words not the right driver for my hardware. A google search on 'intel 82845GL ubuntu' does return other users having similar problems in the past but I haven't been able to pick out a solution in the many many discussions on the subject- partly owed to my 'linux naivety' I guess...but maybe you can help?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Unity 2D is designed for old chipsets such as the 845 and 855 intel series.

Your issues are most probably due to buggy old drivers together with Compiz incompatibilities.

Suggest boot into recovery mode - with network support. Then install unity-2D

I have found with my i855 laptop that I need to boot with an extra grub parameter otherwise I get a similar login screwed up display -

can I suggest that you also see if either grub string i915.modeset=0 or i915.modeset=1 works for your PC. Follow my answer here on how to add it to grub - instructions also include how to fix in grub permanently.

As an alternative to Unity-2D, you could try a light-weight distribution such as Lubuntu (or possibly Xubuntu) which should work much better with very old graphics chipsets such as the i8xx chipsets.

share|improve this answer
    
Yeah, it's down to buggy drivers (& hardware too it seems). I have managed to install and run Unity 2D successfully using the 'nomodeset' option...but the system response is visibly laggy. Any suggestions on what else can be done? –  aateeque Jul 19 '11 at 22:45
    
Both Lucid Karmic will make things worse due to blacklisting and lockup issues - wiki.ubuntu.com/X/Bugs/Mavericki8xxStatus It may be worth experimenting with xubuntu or lubuntu to see if things are better. –  fossfreedom Jul 20 '11 at 21:47
    
I have now moved to Lubuntu and it is amazing! Probably the right choice for this hardware –  aateeque Jul 21 '11 at 18:50
    
That's good news - I'll add this into my answer. –  fossfreedom Jul 21 '11 at 18:52
add comment

The Intel 845 series chips have serious hardware errata. The Windows drivers at the time and the old Linux driver stack didn't exercise the parts of the hardware that don't work, so didn't run into problems.

The new Linux graphics stack (GEM/KMS/DRI2) exercises these hardware features. We disabled the Intel driver on your card because of this. This is why Unity doesn't work for you. See this answer for more details.

The video mode issue would appear to be a different problem. Logs (dmesg and /var/log/Xorg.0.log) are the price of admission for debugging that sort of problem.

share|improve this answer
    
When you say hardware errata...do you mean its buggy hardware? (i.e. stuff that can never be resolved?). I fixed the video problem using 'nomodeset'. I have tried modifying 'xorg.conf' to manually enable the Intel driver as per this page. This just results in a black screen after splash. What else can I do? I'll post dmesg and Xorg.log if it can help –  aateeque Jul 19 '11 at 22:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.