Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a minute or so all my sounds in different videos and formats gets late.

I've tried to reinstall VLC but it didn't help. Please help I can't play any videos because of that.

It's late about 1-2 seconds.

All of the videos work perfectly in movie player!

share|improve this question
1  
Have you tried resetting vlc, either internally or via a purge? –  N.N. Jul 18 '11 at 21:31
    
no, so please tell me how to! –  Alvar Jul 18 '11 at 21:34
    
To purge do sudo apt-get purge vlc and then reinstall. You might want to purge other vlc packages before reinstall too, e.g. vlc-data. I'm not sure if this helps but it will remove vlc as well as its configuration files. –  N.N. Jul 18 '11 at 21:37
    
To reset vlc choose Tools - Settings - Reset settings or the like. –  N.N. Jul 18 '11 at 21:39
    
to purge and then install didn't work... –  Alvar Jul 18 '11 at 21:50
show 4 more comments

closed as too localized by Oli Dec 9 '11 at 21:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers

up vote 11 down vote accepted

VLC and audio lag issues are perhaps more common than they really should be. Under Linux, pulse-audio seems to be a common thread.

However there doesnt appear to be a magic "fix" to cure all.

So here are a few things you could try:

  1. Check that you haven't changed the Audio synchronisation: Tools - Track Synchronisation should be set to zero
  2. Check that other preferences havent affected audio tracking: Tools > Preferences and click the Reset Preferences button
  3. Use Alsa instead of Pulse-Audio for output: From the VLC menu, choose Tools > Preferences > Audio. Change the Output from Default to Alsa
  4. If using Natty - revert to using interrupt driven mode instead of time-scheduled mode

    modify the following line in /etc/pulse/default.pa

    load-module module-udev-detect

    with :

    load-module module-udev-detect tsched=0

Use Alsa instead of Pulse-Audio for output: From the VLC menu, choose Tools > Preferences > Audio. Change the Output from Default to Alsa ^ This works

share|improve this answer
add comment

After todays update to the 1.1.12 version of VLC and using Ubuntu 11.10. Most if not all out of sync problems are gone.

Users need to update their Ubuntu to the latest daily updates which should provide the latest version of VLC (the 1.1.12 version). Already tested and all movies I have seen are working correctly.

share|improve this answer
add comment

I've had exactly the same problem for the last few weeks.

Although I don't have a fix there is a remedy in the menu. I go to Tools > Track Synchronization. This opens a new window. Under the Synchronization tab you'll find Audio/Video - Advance of audio over video - with a window and up and down arrows to offset the audio. I found arrowing -.003 or -.002 seconds is usually pretty close and watchable.

Even though this fixes it enough to watch videos for now, I hope future updates will fix the problem.

share|improve this answer
1  
this isn't a fix this is a workaround, and it's not that good... –  Alvar Jul 18 '11 at 21:38
    
just trying to help, man –  Jeffrywith1e Jul 18 '11 at 22:09
    
There were a bunch of VLC updates today. Hopefully that'll fix the problem. –  Jeffrywith1e Jul 22 '11 at 19:11
add comment

Have you tested to increase the Caching value? It helped to increase it from 300 to 1000 for me. If you stream the files via samba you can increase it under the SMB Access Module.

enter image description here

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.