Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've bougth Steel Storm, Burning Retribution in the Software Center, and every time I run it shows the following message:

You have reached this menu due to missing or unlocable content/data

You may consider adding

-base dir /path/to/game

to your launch commandline

I've gone to main menu in the preferences tab and changed the launcher to no avail.

I've tried running it from console, with /opt/steelstorm-episode2/steelstorm, I got:

Game is Steel-Storm using base gamedir gamedata
Steel-Storm Linux 01:07:07 Jun 11 2011 - release
Playing shareware version.
Skeletal animation uses SSE code path
DPSOFTRAST available (SSE2 instructions detected)
Failed to init SDL joystick subsystem:
couldn't exec quake.rc
couldn't exec default.cfg
execing config.cfg
couldn't exec autoexec.cfg
Client using an automatically assigned port
Client opened a socket on address 0.0.0.0:0
Client opened a socket on address [0:0:0:0:0:0:0:0]:0
Linked against SDL version 1.2.12
Using SDL library version 1.2.14
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce 6150SE nForce 430/PCI/SSE2/3DNOW!
GL_VERSION: 2.1.2 NVIDIA 270.41.06
vid.support.arb_multisample 1
vid.mode.samples 0
vid.support.gl20shaders 1
Video Mode: fullscreen 640x480x32x0.00hz
S_Startup: initializing sound output format: 48000Hz, 16 bit, 2 channels...
Wanted audio Specification:
    Channels  : 2
    Format    : 0x8010
    Frequency : 48000
    Samples   : 2048
Obtained audio specification:
    Channels  : 2
    Format    : 0x8010
    Frequency : 48000
    Samples   : 1024
Sound format: 48000Hz, 2 channels, 16 bits per sample
CDAudio_Init: No CD in player.
Can't get initial CD volume
CD Audio Initialized

If I try -base /opt/steelstorm-episode2/steelstorm says "command not found".

share|improve this question
    
You have to add -base /opt/steelstorm-episode2/steelstorm to the command, not make that the command itself. –  hexafraction Jun 6 '12 at 22:08
add comment

1 Answer

up vote 2 down vote accepted

diagnosis

The error message in the question gives a clue.

Game is Steel-Storm using base gamedir gamedata
couldn't exec quake.rc
couldn't exec default.cfg
execing config.cfg
couldn't exec autoexec.cfg

Steelstorm cannot figure out where the correct base-directory containing the files above.

solution

Fortunately Steelstorm has a parameter which can specify this base-directory

To start the application from the command line you should use the following format:

/opt/steelstorm-episode2/steelstorm -basedir /opt/steelstorm-episode2/

source, post #31

Alternatively, edit the Steel-storm menu option - changing the command line to the above.

For natty you can start the menu application by typing alacarte or using the dash and searching for main menu.

If you do not have alacarte installed - you can install this via:

alacarte Install alacarte

share|improve this answer
    
What happens?... well, it works. Thank you! –  Goytor Jul 18 '11 at 23:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.