Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can use a Windows machine for 10 hours straight without the slightest problem, but after around 15-30 minutes of using ubuntu my eyes become sore and dried out.

I currently have 11.04 installed with a dual-boot Windows XP. Same hardware, eyestrain only with ubuntu.

I've also tried different versions of ubuntu on two different machines. Same eyestrain problem. I've tried combinations of fonts and font rendering and installed the microsoft fonts, although I'm not sure it is related to the fonts anyway because I think the fonts look quite nice.

xrandr shows the monitor refresh rate set at 60hz (the only option for my laptop lcd).

Is there anything else I can try? I'd like to use ubuntu, not windows...

share|improve this question
    
Did you try reducing your screen resolution? –  Thomas W. Jul 18 '11 at 15:38
    
Thanks but reducing the resolution isn't a road I'd like to go down. When I tried it there everything looked awful anyway. –  Kim Jul 18 '11 at 15:44
1  
It will be hard to answer this question unless you can nail down exactly what in Ubuntu puts train on your eyes. Are you using any special theme, background or other setting? –  N.N. Jul 18 '11 at 16:01
2  
Have you tried to adjust the color temperature according to the sun, e.g. with packages.ubuntu.com/natty/redshift ? Also you might benefit from being reminded of taking breaks regularly, see askubuntu.com/questions/34325/… . –  N.N. Jul 18 '11 at 16:06
    
Yes, I agree it's hard to know, but I'm using just the defaults. I've been trying linux mint too. Same problem, but then i go back to windows and my eyes are fine. –  Kim Jul 18 '11 at 16:10

6 Answers 6

If you work at night you can try using redshift. This adjusts the color temperature of your screen so that it get's more redish the later it is. Of course this doesn't really help explain the difference between Windows and Ubuntu but it does reduce stain. Do

sudo add-apt-repository ppa:jonls/redshift-ppa

sudo apt-get update && sudo apt-get install redshift

to install it. There are other programs that do just the same thing as well.

There's also an older version in the repos so sudo apt-get install redshift will suffice.

share|improve this answer
1  
I use Redshift from the repos packages.ubuntu.com/natty/redshift . It's 1.6.1, so is it really necessary to pull it from a PPA? –  N.N. Jul 18 '11 at 16:14
    
no you can of course also just install the package directly. I didn't know it's in the repos –  turbo Jul 18 '11 at 16:41

It may looks rediculous, but I suggest using sharp fonts. It can be a particular perception of smoothed (read 'fuzzy') fonts by your eyes. You may find instructions of how to install sharp fonts here: Script to install sharp fonts

Good luck and repose for your eyes :)

share|improve this answer
    
Thanks for the interesting suggestion. I tried this, and it does change the font, but now my computer looks like it did when I was using Windows 98. :) Not a good solution because I think the proper Ubuntu fonts look great. Anyway, I've tried so many font combinations now that I think the problem may be nothing to do with the fonts. But i dont' know what else... Oh well, maybe one day I'll be able to use Ubuntu without my eyes hurting... –  Kim Jul 18 '11 at 19:51
    
I tried this approach couple of years ago, and I was using sharp fonts successfully for some time. –  Vincenzo Jul 18 '11 at 20:19

I cannot solve your issue. However, I have a similar problem and knowing about this might help you.

On a HP 2230s laptop (matte display, intel graphics), the screen flickers when using Linux and the display is dimmed. Whether the flickering is noticed depends strongly on colours, green background is horrible. I don't always notice the flicker. Some people never see it.

Using the preinstalled Windows Vista, there is no such flicker. At full brightness, the display is fine for me (with Linux).

This effect does not appear to depend on the Linux distribution or version as long as the brightness control works.

Please, document this issue as good as you can. Contact the manufacturer. File a bug against your distribution. Ask friends to describe the quality of your display.

share|improve this answer

For anyone interested this answer might provide solution to eye strain problem on various Linux distro with LCD displays: Laptop screen causes eye strain on all linux distros except Ubuntu and elementary OS

I already found what the problem is. LCD displays uses a frequency known as PWM (Pulse widht modulation). The screen backlight flashes to this frequency, on most monitors is between 200hz - 500hz range.

My Linux distro sets a low PWM frequency by default, that's why all the eyestrain. Luckily Intel gpu drivers can change the PWM frequency.

You need to install intel-gpu-tools

First you need to know your reference clock, this is stored on address 0xC6204. You can read values with the command intel_reg_read, so to read the value you can use the command:

intel_reg_read 0xC6204

Once you know your reference clock you can use the calculator on this page to calculate your desired value. I used 500mhz, so I got 0x7a107a1.

The address for the PWM value is 0xC8254, You can set values with intel_reg_write, so you can use:

intel_reg_write 0xC8254 0x7a107a1

You can see immediately changes. (Sometimes the screen brightness could change, but this is ok, the PWM frequency changes also)

I hope that this info could be helpful to anyone who need it.

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Tim Aug 26 at 10:17
    
@Tom, Since the answer was provided on SE I think it is correct to link to the related post. I thought that rule only applied to 'entire articles' on the Internet. –  Mariusz Miesiak Aug 26 at 13:00
    
Hmm well I would simply copy it as a quote and reference, like I did here: askubuntu.com/a/516224/186134 –  Tim Aug 26 at 13:01
1  
Fair enough. I have already edited my answer –  Mariusz Miesiak Aug 26 at 13:06

Try different font rendering in System>Preferences>Appearance tab Fonts. For the same font, different subpixel hinting can have a huge impact on how the font is percieved. If you have an LCD screen, open Details and try different Hinting to see which works best for you. I like "Slight".

The effect on text in Firefox 3 is different from the effect on the rest of the desktop. Restart Firefox after changing Hinting.

share|improve this answer

While this is only a solution of sorts, I managed to resolve my eye strain problem by buying a new computer. The laptop I was using previously was over five years old, so my eye strain was likely caused by a hardware issue that is no longer relevant.

If you're experiencing eye strain problems, be sure to try Ubuntu on different systems, and I wish you the best of luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.