Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed GNOME 3 on Natty, using the PPA and these instructions. I restarted and tried to log in using Gnome, only to be greeted by a

Oh no! Something has gone wrong.
A problem has occurred and the system
can't recover. Please log out and try again.
Log out

It doesn't give any other details. Where can I access the log or know more about the error or How do I fix the problem?

Specs:
Aspire One ZG5
Ubuntu 11.04

Update:
I tried this from the instructions here

cd ~/.config/autostart
nano gnome-shell.desktop

Then, in the editor, type this:

Code:
[Desktop Entry]
Type=Application
Exec=gnome-shell --replace
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[en_US]=Gnome Shell
Name=Gnome Shell
Comment[en_US]=
Comment=

When I rebooted into GNOME, I did not get the error but I did not get anything else either. Even Unity and Unity 2D failed to load. So, I re-edited gnome-shell.desktop and removed all text. Now when I log in to GNOME, I get the wallpaper and nothing else. I can log in to Unity and Unity 2D though. Also, I have a problem with running software-sources-gtk on the same system. Is it related?

How do I change my video drivers to open source ones? I did not install any drivers while installing Ubuntu, so the drivers are provided by Ubuntu.

Video driver:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)

After updating to GNOME 3, my system settings folder has changed. I do not have a Hardware Drivers option now. How do I update / change my video drivers?

share|improve this question
1  
What video driver? lspci | grep VGA –  wojox Jul 18 '11 at 18:03
1  
One thing you should consider is that GNOME 3 is likely to explode your system - it has a tendency to break multiple system items, and this has been documented in other questions relating to GNOME 3 –  Thomas W. Jul 18 '11 at 18:21
1  
@The Evil Phoenix, this is part of why when I tested GNOME 3 on Ubuntu 10.10, I always just built it myself from the official git repos using jhbuild. Much fewer problems that way. :) –  Christopher Kyle Horton Jul 18 '11 at 20:06
    
@wojox 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03) –  abel Jul 24 '11 at 17:03
1  
@The Evil Am on a test system. It has already broken a few things I guess. –  abel Jul 24 '11 at 17:05

1 Answer 1

up vote 1 down vote accepted

Open a tty, stop gdm (sudo /etc/init.d/gdm stop) (if you are using it) and start X (startx) from the tty. It may give you more info about what is happening. Probably it's a driver problem. Another thing you could try is logging as a different (new) user. Maybe there is some config conflict around. If you are using ATI video card, then shift to open source drivers, because actually G3 is not compatible in almost every case with fglrx.

share|improve this answer
    
stopped gdm, started X server and got a "Could not load session gnome" pop up box. I should try open source video drivers? I am currently on 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03) –  abel Jul 24 '11 at 17:17
    
How do I go about changing my video drivers? –  abel Jul 24 '11 at 17:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.