Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I type Control and any of the arrow keys in any terminal (gnome-terminal, as well as terminator), I get this (or something like it).

It happens when I use openbox as well, so it's not a compiz issue. And it's only in terminal programs, never in a GUI app (such as Firefox, Chrom(ium)e, or Empathy).

share|improve this question
    
What were you expecting Ctrl+arrows to do in a terminal window? –  Colin Watson Jul 18 '11 at 10:43
    
what keyboard do you use and what is your keyboard settings? –  Dirk Hartzer Waldeck Jul 18 '11 at 10:44
    
@colin ctrl+arrow jumps to the end of the next or previous word –  Dirk Hartzer Waldeck Jul 18 '11 at 10:45
    
@Dirk I use the built-in keyboard on my asus 1001p with the 105-key-keyboard settings. Didn't have this issue until last week either. –  jrg Jul 18 '11 at 10:49
    
@James, weird, I had some issue with my keyboard when I selected a different layout from US, but if these settings has worked before you should probably check for a bug report on Launchpad –  Dirk Hartzer Waldeck Jul 18 '11 at 11:01

1 Answer 1

up vote 12 down vote accepted

What is in your ~/.inputrc and /etc/inputrc? The minimum to get those keys working is, I think:

# mappings for Ctrl-left-arrow and Ctrl-right-arrow for word moving
"\e[1;5C": forward-word
"\e[1;5D": backward-word
"\e[5C": forward-word
"\e[5D": backward-word
"\e\e[C": forward-word
"\e\e[D": backward-word

If you have these in /etc/inputrc, the file needs to be included from ~/.inputrc, so check that it has the following line:

$include /etc/inputrc
share|improve this answer
1  
Thanks! That fixed it! –  jrg Aug 10 '11 at 12:02
    
I'm wondering why this is happening in kubuntu 12.10. It's never happened in a previous version before. Is this a bug that needs reporting? –  naught101 Nov 20 '12 at 3:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.