Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using the Keyboard Utility I was able to select the asus layout and after that I was able to get the majority of the function keys to work(screen brightness, wifi, sleep, num lock, and scroll lock). However F9 - F12 (disable/enable trackpad, volume mute, up, and down) do not work.

Does anybody have a fix for that? I've tried the eeepc scripts to see if that would work but it doesn't seem to do anything so far.

Update: After some digging I found some reference to an old acpi edit: http://forum.eeeuser.com/viewtopic.php?id=3573 I was able to follow the instructions however the first instruction requires that you change Power Management to have the acpid and acmd options filled. But this doesn't appear to be in latest version of ubuntu. Does anyone happen to know where to select these options? or is there another script that I would need to edit somewhere?

Also I've checked the asus downloads page and they don't appear to have anything for linux on their site available for download. Any help with this would be appreciated.

Update 2 Aug 2 2011: I upgraded to the ubuntu 11.10 alpha and it looks like my volume hotkeys are working.... I'm not sure what's difference is between 11.04 11.10 keyboard settings... but I guess they've figured it out...

share|improve this question
    
by "upgrading" it probably means that this was a kernel issue. Remember the alpha is very unstable - you perhaps could achieve something similar by restoring a backup of Natty and installing either kernel 2.6.39 or even 3.0. –  fossfreedom Aug 2 '11 at 12:23
    
It looks like the official release of 11.10 has resolved this issue. It's possible that I could have been a kernel issue. Unfortunately I don't know enough about the kernel to thoroughly test it. –  b1ackjosh Oct 25 '11 at 16:30
    
Create an answer with your observation and accept it so that the question can be closed. –  fossfreedom Oct 25 '11 at 16:32
add comment

1 Answer 1

up vote 1 down vote accepted

These issues have been resolved as of the 11.10 update. All hotkeys are working on the new OS, thanks canonical for being awesome.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.