Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a newbie and I just started using the latest Ubuntu. I have a Pavilion DM1 HP netbook and can't find my wifi connection in the network manager.

When i open the "network" thing, there's no "Auto Etho" no "Wireless networks" or "Enable Wireless" and when I go to edit connections then to "Wireless" I can't find my wifi connection, does this mean there's an issue with the wifi itself and how can I fix it?

Ethernet controller : Realtek .... . Network controller Ralink corp. Device 539f at the end, the others are practicly the same USB Controllers, PCI bridges, ISA brige, VGA and other stuff, but the more important are the two that I noted earlier since they're the network related ones.

share|improve this question

3 Answers 3

You should have listed wireless networks as you can see below

enter image description here

If you have a laptop be sure you have it enabled, some laptops have a hardware switch.

If yo still can't find it, try scanning for Additional drivers:

enter image description here

If you still can't find it, please open you're terminal and enter lspci and post the output here.

The ubuntu guide for this issue is posted on ubuntu forums and you can see it HERE.

Oh and Tom below might be right, maybe the driver just doesn't load... open terminal and try:

sudo modprobe rt3090sta

And if it works add this diver to your permanent driver list so it loads at start with:

gksu gedit /etc/modules

and paste rt3090sta at the end of the file and save.
(or just do it with vi, whatever is easier for you)

good luck!

share|improve this answer
    
when I used the "additional drivers they said "no proprietary drivers are in use on this system" and before they showed some kind of warning saying I should check my network connection, I guess it's because I don't have any :(. and here is the outpout for the lspci : –  Tchock Jul 17 '11 at 19:30
    
ubuntuforums.org/showthread.php?t=1776880 I think that this is it, I'm going to do what they told me to, is it really it danizmax ? Because my netbook is also a Pavilion dm1 by HP ! –  Tchock Jul 17 '11 at 19:42
    
Yes! looks like you did good job on finding guide with RPMs xD, but RPMs are for suse not ubuntu. Ubuntu uses deb packaged... I found a guide for ubuntu, I updated my post. –  danizmax Jul 17 '11 at 22:01

Before anything, make sure your hardware WiFi switch is on. Then click the system tray Network icon and insure that both Enable Networking and Enable Wireless are on.

Method 1:

If you know the SSID of your wireless network, click the WiFi icon in the tray, then click Connect to Hidden Wireless Network then type the SSID of your network in the Network Name box.

Image

Next, select your network security type (if any) and enter your key.

Image

When you are done with that, click Connect. It should connect you to your wireless network.

If it doesn't work, make sure you entered your key correctly by clicking the Show key box.

Method 2:

Try accessing your wireless router (or access point) with another computer or OS. Look for a Broadcast SSID option. Turn this on if it is off, then save settings. This will (hopefully) allow your computer to see the network.

Hope this helps!!

share|improve this answer

Try the following. Unfortunately, I'm not at my home computer right now, and typing explanations on a smartphone is frustrating at best...

Open a terminal window and edit /etc/modules as 'root'. I'll use vi as an example:

sudo vi /etc/modules

Move your cursor to the end of the file, press o, then enter:

rt3090sta

Press ESC to exit edit mode.

Press :wq to exit the editor.

Reboot.

If this works, I'll explain why later; if it doesn't, I'm sure someone else will jump in and help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.