Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I think something changed in maybe the Linux core which has broken Ubuntu and practically every other Linux install on my laptop.

The problem is that suddenly the back-light doesn't work when I run Ubuntu. This means that I can faintly see the Ubuntu login screen but as the screen isn't emitting light its impossible to use.

There is a way I can use it. If I jump into the - grub? - menu when pressing shift on start up I can choose a previous version of Linux / Ubuntu and it all runs fine. Unfortunately... without doing that it doesn't work.

I have tried a variety of installs including Kubuntu - I thought this had a different display or GUI thing but no dice.

Has anyone heard of this happening to other people? Is there a fix around?

Its an emachines E525 laptop.

share|improve this question
Are you sure that the problem is operating system related? If your laptop is old, your screen back-light might be problematic. – Mustafa Zengin Jul 17 '11 at 19:43
@JasonS, can you provide us with a couple specific GRUB entries to show us what works and what doesn't? If it's kernel-related, that might help. – Christopher Kyle Horton Jul 17 '11 at 20:13
Mustafa - Yes. 10.10 works fine. It was only when upgrading to 11.04 that this occured. – JasonS Jul 18 '11 at 17:45
Warrior - Sorry. I don't know. I tap shift. I get a little menu. I select Previous Versions. I then have 2 options. Previous version or Previous version safe mode. This works. If I run Ubuntu without selecting previous version the problem above occurs. – JasonS Jul 18 '11 at 17:47

I've had a similar problem - it's a problem caused by one of the changes to the kernel, although I'm not sure where this is located in the kernel configuration menu. {Presumably one way of solving it would be to track down the source of it in the kernel config menus and recompile the kernel with the offending feature deselected.}

A quick fix solution is to use the command

sudo setpci -s 00:02 F4.B=0

which tells your computer to restore power to the backlight. I appreciate that it's a bit difficult to open up a terminal window if you can't see what you're doing, so you might want to set a keyboard shortcut like Ctrl-T to open a terminal. Hope this helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.