Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got Firefox 5 installed on my Ubuntu 11.04 system. I would like to have webgl working, which is not right now: this website just gives me a grey page:

http://webglsamples.googlecode.com/hg/aquarium/aquarium.html

I've got it working on google-chrome using the nvidia proprietary drivers, so there must be a way to get it to work on the same system in Firefox.

share|improve this question

5 Answers 5

up vote 5 down vote accepted

It is my understanding that it is already enabled. I have checked the aquarium out with Firefox 5 right now. Works perfect. It was in Firefox 4 that you needed a command to activate WebGL (Although the programs ran horribly). On Firefox 5 WebGL is much better. Not as good as Chrome of course but it is catching it up very fast.

If you are still having problems seeing that webpage it is because of a direct problem with your video card. Does your video card support opengl 2.0.

Here is a mini guid that points from what version the browsers support WebGL and what to do to make it work if it is in Alpha/Beta with the browser: http://www.khronos.org/webgl/wiki/Getting_a_WebGL_Implementation

In the Wikipedia: http://en.wikipedia.org/wiki/Firefox_4 you can see that in Firefox 4 it got some support for WebGL (But trust me, most WebGL examples from Chrome Labs tested horrible)

In the Wikipedia:http://en.wikipedia.org/wiki/History_of_Firefox#Version_5.0 you can see that Firefox 5 got more support for WebGL that now actually lets you play most WebGL apps. There are some even that are very tough to support and it supports them like http://www.ro.me/ "3 Dreams of Black" which is literally you flying inside a video thats playing cool music.

share|improve this answer
1  
upon further investigation, it looks like Firefox is blocking my drivers: askubuntu.com/questions/53460/… –  213441265152351 Jul 17 '11 at 15:35

Indeed this seems to be an issue linked to Firefox blocking graphics card drivers: I have Kubuntu 11.04 and Firefox 6 and Chromium 12.0.742.112 (90304) Ubuntu 11.04 and in FF I get a grey page, in Chromium I get to see some fish. Performance is not very good, I get 16-22fps even with 1 fish.

UPDATE: actually the number of fish does not seem to link in any way with fps: 1000 fish and I still get 16-22fps. The same is true for any number of fish I set and any perspective.

share|improve this answer

It is the same in Chrome. It is a problem with the code, not your browser or WebGL.

share|improve this answer

This worked for me with Firefox 5 and Ubuntu 11.04, although the aquarium demonstration link you provided ran extremely slowly on my machine, which admittedly isn't set up for gaming or multimedia. YMMV.

share|improve this answer

check about:config webgl and change webgl.force-enabled to true. worked for me to enjoy using the webgl ;-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.