Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been having some problems with getting an USB drive to appear. First I connected it to my Ubuntu laptop and the drive appeared and I could format it with the ext file system. Then I moved the drive to another computer that is also running Ubuntu and the drive won't appear in GParted or other tools. Could you recommend a way to proceed? Thanks

UPDATE. Here's the output from $ dmesg | tail

[245126.162668] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
[245128.122950] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
[245128.186959] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
[245128.554783] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
[245129.050730] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
[245132.522971] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
[245132.578123] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
[245133.466497] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
[245134.627949] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
[245135.574092] [drm] nouveau 0000:01:00.0: no space while hiding cursor

...

[257116.514694] scsi6 : usb-storage 2-6:1.0
[257117.545565] scsi 6:0:0:0: Direct-Access     WD       5000AAKB Externa l108 P
Q: 0 ANSI: 0
[257117.546254] sd 6:0:0:0: Attached scsi generic sg4 type 0
[257117.549423] sd 6:0:0:0: [sdc] 976773168 512-byte logical blocks: (500 GB/465
 GiB)
[257117.550426] sd 6:0:0:0: [sdc] Write Protect is off
[257117.550430] sd 6:0:0:0: [sdc] Mode Sense: 03 00 00 00
[257117.551416] sd 6:0:0:0: [sdc] No Caching mode page present
[257117.551422] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[257117.554039] sd 6:0:0:0: [sdc] No Caching mode page present
[257117.554043] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[257117.557055]  sdc: sdc1
[257117.559543] sd 6:0:0:0: [sdc] No Caching mode page present
[257117.559548] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[257117.559552] sd 6:0:0:0: [sdc] Attached SCSI disk

And new output from $dmesg | tail

ubuntu@ubuntu:~$ dmesg | tail
[  128.502416] usbcore: registered new interface driver usblp
[  130.703847] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[  130.703909] HDA Intel 0000:00:1b.0: irq 44 for MSI/MSI-X
[  130.703935] HDA Intel 0000:00:1b.0: setting latency timer to 64
[  135.755667] lp0: using parport0 (interrupt-driven).
[11469.094303] EXT4-fs (sdc1): VFS: Can't find ext4 filesystem
ubuntu@ubuntu:~$ 
share|improve this question
1  
did you unmount the drive first before moving the drive? –  fossfreedom Jul 17 '11 at 6:57
    
Not sure. I'm still investigating this. The drive neither appears in ubuntu nor ms-windows –  Niklas rtz Jul 22 '11 at 12:17
1  
is it one of these Western Digital disks that you have security enabled via "My Passport"? - you may need to run it to unlock the drive via MS Windows. –  fossfreedom Jul 22 '11 at 12:36
    
Thanks for the update. It is LaCie 1 TB that I now connected to MS_Windows XP to see how it appears. Either Linux or MS-Windows should be able to get some contact. –  Niklas rtz Aug 14 '11 at 18:34
1  
If you've formatted with ext then Windows should think that its unformatted and ask to format it. If it doesnt, possibly a faulty drive? Can you force mount it (see my answer)? –  fossfreedom Aug 14 '11 at 18:43

2 Answers 2

up vote 1 down vote accepted

Can you force mounting of the drive?

sudo mkdir /media/LaCie
sudo mount -t ext4 /dev/sdc1 /media/LaCie -o force

A couple of pointers - ext4 is the drive format - if you formatted with ext2 or 3 then use "ext2" or "ext3" respectively.

Also "/dev/sdc1" is the device name linux sees your drive. You can see what device name is by running dmesg.

N.B. check that the drive is being seen - first boot without your drive - run dmesg - plug in your drive and run dmesg again.

If no output is displayed - then my strong guess is that you have a defective drive.

Your question had some initial dmesg trace - if you no longer have any output then my strong guess was that your drive was dying - and now has died.

Similarly - if Windows does not offer to format the drive when it is plugged in, this is another strong indicator that the drive has failed.

As to why - external drives are like other drives - if you moved/bumped the drive whilst in use it could cause corruptions. In rare causes - cause it to fail.

Drives are mechanical - any sort of weak mechanical link/electrical failure would cause what you are seeing.

share|improve this answer
    
Trying: sudo mount -t ext4 /dev/sdc1 /media/LaCie -o force mount: wrong fs type, bad option, bad superblock on /dev/sdc1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so –  Niklas rtz Aug 14 '11 at 18:57
1  
not sure that I understand - when you plug in the drive, does it mount to /dev/sdc1? In that case you should see it mount in nautilus - alternatively umount /dev/sdc1 and mount as per my answer - obviously change ext4 to ext3. –  fossfreedom Aug 21 '11 at 8:57
1  
ok - if something else is mounted to /dev/sdc1 then you'll need to find the device it is trying to mount as now - previously in your question you ran dmesg | tail - what is it trying to mount now? /dev/sdd1 ?? –  fossfreedom Aug 22 '11 at 19:31
1  
Niklas - if you first boot without your drive - run dmesg - plug in your drive and run dmesg again. If no output is displayed - then my strong guess is that you have a defective drive. –  fossfreedom Aug 22 '11 at 20:07
1  
I've updated my answer with our findings so far. –  fossfreedom Aug 22 '11 at 20:24

Can you mount it manually? Run

dmesg | tail

Find out which drive it's using. Then:

sudo mount /dev/sdXY /mnt

Replacing the /dev/sdXY with what ever port it is.

EDIT:

Run:

sudo mount /dev/sdc1 /mnt

Then:

cd ls /mnt
share|improve this answer
    
I tried running dmesgand got some mysterious output I pasted above –  Niklas rtz Jul 16 '11 at 17:48
1  
Plug in the drive and immediately run that command. –  wojox Jul 16 '11 at 23:08
    
Thanks for the help. I ran the command but couldn't dedoce the output. It's pasted above. –  Niklas rtz Jul 17 '11 at 6:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.