Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can find it listed when I search for "zsnes" in the Ubuntu Software Center but it doesn't have the "Install" button. If I click the "More information" button I'll get a "package not found" message.

Synaptic can't find this package either.

(from user @REJ) I have Natty 64bit. When I run sudo apt-get install zsnes it gives the following output:

Reading package lists... Done Building dependency tree
Reading state information... Done Package zsnes is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'zsnes' has no installation candidate
share|improve this question

3 Answers 3

zsnes exists in the Universe repository for 32bit Natty only.

If you look here on launchpad for the zsnes package, you'll note there is no 64bit package available - just the 32bit (i386) package.

To get this to work under 64bit requires a bit of terminal work...

Download the 32bit package from here into your Downloads folder.

Install all the dependencies:

sudo apt-get install libao4 libc6 libgcc1 libgl1-mesa-glx libpng12-0 libsdl1.2debian libstdc++6 zlib1g

Then do the following:

cd ~/Downloads
dpkg -x zsnes_1.510-2.2ubuntu4_i386.deb zsnes_dir
cd zsnes_dir/usr/bin

You can now run the application by running

./zsnes -ad sdl

source

share|improve this answer

simply run this command first

apt-get build-dep zsnes

It'll download and install all the 32bit dependencies to get zsnes to run. Next you just install zsnes as usual using this command

apt-get install zsnes

finally, after you have successfully installed zsnes we just want to get rid of the dependencies we needed to install/build it by simply running this command

aptitude markauto $(apt-cache showsrc zsnes | grep Build-Depends | perl -p -e 's/(?:[\[(].+?[\])]|Build-Depends:|,|\|)//g')
share|improve this answer

I thought I'd share a different strategy that I ran across in the search for installing ZSNES on amd64.

If you don't mind using a different emulator (a better one in my opinion), there is a port of SNES9x available.

First, add these sources to your "sources.list" file in "etc/apt".

to edit the file as root, open your terminal and type:

cd etc/apt
sudo gedit sources.list

Once that is opened, add these two lines into the textfile, and save:

deb http://ppa.launchpad.net/bearoso/ppa/ubuntu raring main deb-src http://ppa.launchpad.net/bearoso/ppa/ubuntu raring main

ALSO, REPLACE "raring" WITH WHATEVER VERSION OF UBUNTU YOU ARE RUNNING CURRENTLY.

Then, in your terminal, type:

sudo apt-get update

Once that is done, install the program using this command:

sudo apt-get install snes9x-gtk

Once installed, just search for the app in your dashboard, and run it!

Config is simple, and it's a great emu in my opinion, it's been around for years, and this port works great so far.

-Chris

share|improve this answer
1  
The recommended way to add a PPA is to either add ppa:bearoso/ppa as the deb line entry in the Software and Updates tool or to run sudo add-apt-repository ppa:bearoso/ppa from the Terminal. More detailed instructions can be found from askubuntu.com/q/4983/8973 –  papukaija Jul 1 '13 at 23:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.