Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm facing a problem with Blu-ray (.mkv) videos on my PC. When the video is playing sometimes it just freezes or plays quickly, but the sound goes on and later the video starts playing properly.

I tried switching to different media players (Movie player, splayer, vlc player) but the same problem occurs.

Also, I reconfigured the graphics card settings but I'm easily able to play HQ games.

Graphics card - ATI Radeon HD3470
PC - Sony VAIO FW
Ubuntu 11.04

share|improve this question
    
Be careful because I've always gotten choppy video playback when using the ATI-proprietary drivers (fglrx). The Open Source ones work much better for me. –  Niklas Oct 7 '11 at 13:22

2 Answers 2

Big videos like that can choke video cards if they don't have native codec support. Best bet is to check your video card drivers are up to date, in the past I've had trouble getting drivers for ATI cards. Yours is old enough that ubuntu should have them in the restricted hardware thingy.

share|improve this answer
1  
I don't think I would recommend the proprietary drivers for Radeon cards in Ubuntu anymore. I've had much better experiences with the open radeon driver. –  Jo-Erlend Schinstad Oct 7 '11 at 13:58

You should probably enable frame dropping and/or disable the loop filter on high definition movies. For example, on UMplayer/SMplayer these can be found on prefences --> performance.

You should also experiment with some options about the video output . On the above mentioned players, you can find it on general --> video --> output driver. This should probably not be needed if you disable the loop filter above but it has proved useful to me in the past.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.