Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I've tried to compile kernel with grsec patch to increase security of my machine. Compilation went even smoothly, but after running new kernel system runs until xserver starts.

Here's tailed dmesg:

[ 43.753694] [drm:radeon_cs_ioctl] ERROR Invalid command stream !
[ 45.917078] Forbidden register 0x4028 in cs at 40
[ 45.917082] [drm:radeon_cs_ioctl] ERROR Invalid command stream !
[ 45.918384] Forbidden register 0x4028 in cs at 40
[ 45.918387] [drm:radeon_cs_ioctl] ERROR Invalid command stream !
[ 45.918654] Forbidden register 0x4028 in cs at 40
[ 45.918656] [drm:radeon_cs_ioctl] ERROR Invalid command stream !

Steps which I've compiled kernel source:
1) instaled needed packages for compiling kernel source
2) downloaded matching kernel version for grsec and unpacked to /usr/src/
3) applied grsec patch
4) copied and loaded config of current kernel from /boot
5) compiled and made .deb package
6) installed and rebooted

Any advice for this problem? I cannot run xserver letting network connect to my wifi network with wpa2.

share|improve this question
    
You've accepted the answer given but it does not solve your problem, have you solved it yourself or do you still need an answer? –  Mark Rooney Feb 24 '12 at 10:08
add comment

2 Answers

up vote 1 down vote accepted

Did you remove your old kernel from grub? If not, boot into that kernel. (For future reference, leave your old kernel in grub until you try a new kernel.)

Right now, I'd suggest booting from a LiveCD, chrooting, and restoring the default kernel to get you back into your system. It's a similar process to restoring Grub (documented here: https://help.ubuntu.com/community/GRUB2) but you'll want to redo the kernel rather than grub.

share|improve this answer
    
No David, I've left old kernel for backup so I can boot system on old one and works find. I'm wondering whats the problem with -grsec kernel and how to resolve xorg not working properly :) –  Adrian K. Jul 16 '11 at 6:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.