Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

since some days my Files lens opens only nautilus but not the correct application which is associated with the file extension. For example, if I choose a PDF file, Nautilus is openend, pointing to the directory there the file is (and the file is selected) but Adobe Reader is not opened.

Then I do the same in the terminal with

xdg-open sample.pdf

only Nautilus is opened too.

xdg-mime shows me this info:

$ xdg-mime query default application/pdf
acroread.desktop

The /usr/share/applications/acroread.desktop file:

[Desktop Entry]
Name=Adobe Reader 9
MimeType=application/pdf;application/vnd.fdf;application/vnd.adobe.pdx;application/vnd.adobe.xdp+xml;application/vnd.adobe.xfdf;
Exec=acroread 
Type=Application
GenericName=PDF Viewer
Terminal=false
Icon=AdobeReader9
Caption=PDF Viewer
X-KDE-StartupNotify=false
Categories=Application;Office;Viewer;X-Red-Hat-Base;
InitialPreference=9

The same with other file types like images, music files and office documents.

Then I doubleclick the file in Nautilus everything is ok and the correct applications are opened.

I assume this behaviour has something to do with Thunar which I've installed some days ago but deinstalled after these problems.

Any suggestions?

share|improve this question
add comment

2 Answers

up vote 6 down vote accepted

I had the same problem when I installed xfce (my question can be found here).

My problem was solved after uninstalling all xubuntu*, xfdesktop4* and xfce4* packages (and thunar).

Perhaps you should start by typing:

aptitude search xfce xfd xubuntu | grep ^i

in order to see which packages are installed in your system.

Then proceed with their uninstallation.

share|improve this answer
    
Pavlos, thank you, this is the solution. Awful, that the deinstallation of Thunar don't remove all dependencys, which are installed due of it. –  che--- Jul 15 '11 at 16:08
    
Glad to hear that it worked ;) I agree that it's kind of messy though... –  Pavlos G. Jul 15 '11 at 16:28
    
This bug still happens in 12.04. :( –  NoBugs Apr 11 '12 at 22:30
    
I could track it down to the 'exo-utils' package, where I probably have used exo-preferred-applications from once. In ~/.local/share/applications there is the following entry, which appears to cause it, if exo-file-manager is installed: "mimeapps.list:x-scheme-handler/file=exo-file-manager.desktop" –  blueyed Dec 9 '13 at 23:08
    
Ran into this issue on a system that had been originally installed using the xfce-based mythbuntu distro CD. Uninstalling the xfce related packages worked. If it still doesn't work, try manually setting the default browser –  TrinitronX Jan 10 at 4:32
add comment

I had the same issue with the files-lens as well as in Chrome browser. I removed all xfce4 related packages and it fixed the issue. Thanks!

This is what I did,

sudo aptitude purge xfce4 desktop-base exo-utils gtk2-engines-xfce libexo-1-0 libexo-common libgarcon-1-0 libgarcon-common libthunarx-2-0 libtumbler-1-0 libxfce4ui-1-0 libxfce4util-bin libxfce4util-common libxfce4util4 libxfconf-0-2 orage tango-icon-theme thunar thunar-data thunar-volman tumbler tumbler-common xfce-keyboard-shortcuts xfce4 xfce4-appfinder xfce4-mixer xfce4-panel xfce4-session xfce4-settings xfce4-utils xfconf xfdesktop4 xfdesktop4-data xfwm4 xfwm4-themes

I found this information here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.