Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

since some days my Files lens opens only nautilus but not the correct application which is associated with the file extension. For example, if I choose a PDF file, Nautilus is openend, pointing to the directory there the file is (and the file is selected) but Adobe Reader is not opened.

Then I do the same in the terminal with

xdg-open sample.pdf

only Nautilus is opened too.

xdg-mime shows me this info:

$ xdg-mime query default application/pdf

The /usr/share/applications/acroread.desktop file:

[Desktop Entry]
Name=Adobe Reader 9
GenericName=PDF Viewer
Caption=PDF Viewer

The same with other file types like images, music files and office documents.

Then I doubleclick the file in Nautilus everything is ok and the correct applications are opened.

I assume this behaviour has something to do with Thunar which I've installed some days ago but deinstalled after these problems.

Any suggestions?

share|improve this question
Possible duplicate of Using gnome-open to open pdf files – Pandya Mar 10 at 14:33
up vote 9 down vote accepted

I had the same problem when I installed xfce (my question can be found here).

My problem was solved after uninstalling all xubuntu*, xfdesktop4* and xfce4* packages (and thunar).

Perhaps you should start by typing:

aptitude search xfce xfd xubuntu | grep ^i

in order to see which packages are installed in your system.

Then proceed with their uninstallation.

share|improve this answer
Pavlos, thank you, this is the solution. Awful, that the deinstallation of Thunar don't remove all dependencys, which are installed due of it. – che--- Jul 15 '11 at 16:08
Glad to hear that it worked ;) I agree that it's kind of messy though... – Pavlos G. Jul 15 '11 at 16:28
This bug still happens in 12.04. :( – NoBugs Apr 11 '12 at 22:30
I could track it down to the 'exo-utils' package, where I probably have used exo-preferred-applications from once. In ~/.local/share/applications there is the following entry, which appears to cause it, if exo-file-manager is installed: "mimeapps.list:x-scheme-handler/file=exo-file-manager.desktop" – blueyed Dec 9 '13 at 23:08
Ran into this issue on a system that had been originally installed using the xfce-based mythbuntu distro CD. Uninstalling the xfce related packages worked. If it still doesn't work, try manually setting the default browser – TrinitronX Jan 10 '14 at 4:32

I had the same issue with the files-lens as well as in Chrome browser. I removed all xfce4 related packages and it fixed the issue. Thanks!

This is what I did,

sudo aptitude purge xfce4 desktop-base exo-utils gtk2-engines-xfce libexo-1-0 libexo-common libgarcon-1-0 libgarcon-common libthunarx-2-0 libtumbler-1-0 libxfce4ui-1-0 libxfce4util-bin libxfce4util-common libxfce4util4 libxfconf-0-2 orage tango-icon-theme thunar thunar-data thunar-volman tumbler tumbler-common xfce-keyboard-shortcuts xfce4 xfce4-appfinder xfce4-mixer xfce4-panel xfce4-session xfce4-settings xfce4-utils xfconf xfdesktop4 xfdesktop4-data xfwm4 xfwm4-themes

I found this information here

share|improve this answer

It is a bug in exo-utils / exo-file-manager.desktop:

share|improve this answer

This is a bug, but one way of solving (working-around) the problem is to make your own version of xdg-open:

mkdir -p ~/bin
cp /usr/bin/xdg-open ~/bin

You will need to make sure you have ~/bin added to your path. Your ~/.bashrc file should contain something like the following in it (it may already be there):

if [ -d ~/bin ]; then
    export PATH=~/bin:$PATH

Now you need to edit ~/bin/xdg-open and add the following line after the line which only contains the text detectDE in it (around line 525 in my version of the script):


After logging out and back in, documents should open with their associated handlers, instead of with Nautilus.

share|improve this answer

I solved deleting (or commenting with a #) this line from file ~/.local/share/applications/mimeapps.list:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.