Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I copied my 3 cds into one directory and ran the installer from there with Wine. It installed perfectly fine. I was even able to watch the intro, navigate all the menus and start a game. However, about 1-30 seconds after starting the game, I get the infamous "Age of Empires 3 has encountered a problem and needs to close" pop-up with the "send/don't send" buttons. I was unable to determine any error from that.

I ran it from a terminal and I believe the important part of the output is:

err:eventlog:ReportEventW L"age3.exe"
err:eventlog:ReportEventW L"4.105.919.3236"
err:eventlog:ReportEventW L"deformerdll.dll"
err:eventlog:ReportEventW L"0.0.0.0"
err:eventlog:ReportEventW L"00001363"

Can someone tell me what this means and what I need to do to get AoE3 working?

I looked on the cd for deformerdll.dll and also checked Winetricks for it. I didn't find it.

Note: I have already tried the methods suggested at WineHQ and it still doesn't work.

For anyone interested in the whole several page output of terminal, here it is.

share|improve this question
2  
I think the wine mailing list is more appropriate than the askubuntu page - there are more people who know about wine than here. –  cweiske Jul 15 '11 at 10:44
    
I would suggest you take a look at Codeweavers: Crossover Games I've a friend who uses it and says it runs games such as World of Warcraft flawlessly, and others like The Witcher etc. I know this isn't really an answer but just thought you might be able to give it a shot? Hope it helps you somehow! –  zkriesse Jul 15 '11 at 23:07
1  
@zkr Well, my budget is zero. Thanks for the suggestion though. PlayOnLinux worked for me. –  John Jul 16 '11 at 1:43
    
@cwe I will keep that in mind for any more questions I may have. –  John Jul 16 '11 at 1:43
    
No worries @John just thought I'd suggest it :) –  zkriesse Jul 16 '11 at 1:54

2 Answers 2

up vote 6 down vote accepted

You're best chance to install this is using PlayOnLinux Install PoL as it'll configure wine to work with Age Of Empires III (and the various expansions) for you.

share|improve this answer

You may want to check the WineAppDB. I believe this addresses your problem, no?

share|improve this answer
    
Um, no. Been there, done that. About 3 times. And the method that's guaranteed to work? I followed the link, and they didn't have that wine version anymore. –  John Jul 15 '11 at 1:39
    
Well, I tried, sir. You can always try to downgrade your wine version via terminal. –  Kick Jul 15 '11 at 20:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.