Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Realtek RTL 8190 (802.11n) Wireless controller.

> lspci -v | grep Network
04:01.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8190

I first installed the driver rtl8192se_linux_2.6.0010.1012.2009_64bit.tar.gz, but apparently that does not work for the 8190.

On searching deeper, I found that I should use ndiswrapper with the Windows drivers, following these instructions. I downloaded the 64-bit drivers, installed them with ndiswrapper, and verified that the installation worked:

$ ndiswrapper -l
net819xp : driver installed
    device (10EC:8190) present

But still the driver does not work:

$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

I read that I needed to execute sudo modprobe ndiswrapper to start it, but that didn't change a thing.

Does anybody have any insights? Is the rtl8192se driver maybe conflicting? How do I remove that one?

share|improve this question
add comment

1 Answer

From the Ubuntu Forums

Step 1:- Install NDISWrapper and Blacklist Native Driver

echo -e 'blacklist rtl8190\nblacklist wl' | sudo tee -a /etc/modprobe.d/blacklist
sudo apt-get install ndiswrapper-utils-1.9
mkdir ~/rtl8190; cd ~/rtl8190

Note bodhi.zazen - You probably need to reboot after blacklisting wl ;)

Step 2: Copy (the windows drivers) "rtl8190p.sys" and "net8190.inf" to ~/rtl8190

Step 3: Configure NDISWrapper (and WPA Supplicant)

sudo ndiswrapper -i net8190.inf
ndiswrapper -l
sudo depmod -a
sudo modprobe ndiswrapper
sudo cp /etc/network/interfaces /etc/network/interfaces.orig
echo -e 'auto lo\niface lo inet loopback\n' | sudo tee /etc/network/interfaces
sudo ndiswrapper -m
echo 'ndiswrapper' | sudo tee -a /etc/modules
echo 'ENABLED=0' | sudo tee -a /etc/default/wpasupplicant
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.