Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Software Sources, I have Update Manager set to check for updates DAILY. I also selected the setting to Notify but not to download or install updates.

Considering my settings, Why do I not receive Daily notifications when updates are available?

For example, Google Chrome PPA released a SECURITY update Tuesday. Yet as I write this my Update Manager has not alerted me that there is an update available for my Google Chrome PPA. From past experience I know that if I manually run Update Manager the Chrome PPA update will be available.

How do I get Update Manager to CHECK and NOTIFY for updates DAILY? I do not want to have to manually run Update Manager on a daily basis to see if there are updates available.

This happens on both Lucid and Natty.

In Startup Applications - Update Notifier is enabled.

share|improve this question
    
10.04 and 11.04 (desktop and laptop) –  Nick Jul 14 '11 at 20:48
    
I think I got it! gconf-editor: apps/update-notifier/regular_auto_launch_interval. Mine was set to 7. I changed it to zero (0). THANK YOU for your help fossfreedom (or whoever posted that pic about checking gconf-editor's auto_launch setting. This is what ultimately led to me solving this. thank you so much! –  Nick Jul 14 '11 at 22:16
    
indeed - changed the piccy. –  fossfreedom Jul 14 '11 at 22:27

2 Answers 2

Using gconf-editor check that the Auto-Launch checkbox as shown in this image is ticked.

(As found by Nick) - check also that the option (highlighted) "regular_auto_launch_interval" is set to zero.

enter image description here

share|improve this answer
    
If I change my settings to "Install Security Updates without confirmation" will this cause the Update Manager to CHECK & INSTALL for updates DAILY? Update Notifier is activated on my box. All I want is for the Update Manager to do what the settings say: check daily for updates and if update/s are available notify me. Why doesn't it do this? –  Nick Jul 14 '11 at 21:07
    
auto_launch is ticked on my box. I know Update Manager works because I do get notifications about updates. It's just that the notifications are not timely. For example, if I wait long enough (maybe a week), Update Manager will notify me about the Google Chrome PPA update. I can post an image of my gconf-editor update-notifier settings if this will help. But I don't know how to paste/post the image here as a comment. –  Nick Jul 14 '11 at 21:25

In dash type "software sources" and return to select it. The parameter you want is on the Updates tab "Automatically check for updates".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.