Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I open magnet links with firefox? I tried setting following values in about:config,

network.protocol-handler.app.magnet -> /usr/bin/deluge
network.protocol-handler.expose.magnet -> true
network.protocol-handler.external.magnet -> true

But firefox keeps on complaining about

Firefox doesn't know how to open this address, because the protocol (magnet) isn't associated with any program.

I am using repository version of firefox (5) and deluge (1.3.1 - gui+daemon mode) on ubuntu 11.04

Edit: I was told to set network.protocol-handler.expose.magnet to false and firefox would ask which application to use, but I see no box asking me something appearing.

share|improve this question
    
@Eyal Good idea. I've flagged this question for merging with one of the dupes. This will move all answers over. –  Seth Mar 13 '13 at 0:11
add comment

5 Answers 5

up vote 8 down vote accepted

as of firefox 3.6 network.protocol-handler.external.* seems to no longer work

in about:config

network.protocol-handler.expose.magnet -> false

and 'reset' all other values to do with magnet.

once you click a magnet link you will be prompted to choose an application, navigate to and select /usr/bin/deluge

You might also try

$ gconftool-2 -t string -s /desktop/gnome/url-handlers/magnet/command 'deluge "%s"'
$ gconftool-2 -t bool -s /desktop/gnome/url-handlers/magnet/needs_terminal false
$ gconftool-2 -t bool -s /desktop/gnome/url-handlers/magnet/enabled true
share|improve this answer
    
Yes, I tried this (including the reset) but it didn't ask anything. The thing is this worked with Transmission (default app), but after I uninstalled transmission I can't get it to point to deluge in any way. –  KillianDS Jul 18 '11 at 6:43
    
Strange, worked for me. I've added the steps for changing gnome's default url handling, dont think firefox takes any notice of it but its worth a try. –  Smithamax Jul 18 '11 at 8:02
    
Okay, thanks, I'll try it again as soon as I get home. –  KillianDS Jul 18 '11 at 8:04
1  
the other thing to check is in firefox's preferences under applications, if there is already an entry for magnet. –  Smithamax Jul 18 '11 at 8:52
    
Well, selecting "use..." there and manually going to /usr/bin/deluge did the trick, thank you :)! –  KillianDS Jul 18 '11 at 21:53
add comment

In Firefox go to Edit/Preferences/Applications, search magnet and set Deluge

enter image description here

share|improve this answer
add comment

Instead of clicking on the magnet link in Firefox (which requires some advanced configuration to set up), right-click on the link and select "Copy Link Location". Then, move into your Deluge window, click Add Torrent (the "+" at the top-left of the window), and then click the "URL" button.

Happy torrenting, and remember to go for a 3:1 seed ratio!

share|improve this answer
    
Well, it's not really that advanced, but that can be solved with a quick google search (I would tell you if I actually remembered how, I'm kind of a noob too). –  WindowsEscapist Jun 23 '12 at 22:59
add comment

was trying to get magnets to open with deluge in chrome rather than firefox but after trying everything else i had seen i finally managed to make magnet links open in deluge by not only changing

MimeType=application/x-bittorrent;

to

MimeType=application/x-bittorrent;x-scheme-handler/magnet;

in /usr/share/applications/deluge.desktop but also removing

x-scheme-handler/magnet;

from /usr/share/applications/transmission-gtk.desktop before running

sudo update-desktop-database

hope this helps anyone with similar problems

share|improve this answer
add comment

Have you actually installed deluge? If not, open a terminal and enter this command. sudo apt-get install deluge When its done it should show up in the programs list.

share|improve this answer
    
I think that the problem is he doesn't know how to get it to link with firefox (e.g. he clicks a magnet link and then firefox wants to know what to open it with and asks him to browse to the executable). –  WindowsEscapist Jun 23 '12 at 22:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.