Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Firefox as my default browser.

Email is a Chromium webapp pinned to the launcher, with a Google Apps account so it's basically GMail.

Most solutions involve the 'desktop-webmail' application that doesn't work in Unity, or setting the default browser to handle the mailto: links.

Can I set Firefox, Chromium and maybe even Nautilus to use my Chromium webapp?

share|improve this question
    
desktop-webmail does work but, no, you can't set the browser. –  Lightbreeze Jul 14 '11 at 14:25
add comment

1 Answer 1

up vote 1 down vote accepted

Create a custom script with e.g. name "mystarter.sh" (make it executable) , paste inside it the two line command:

#!/bin/bash

/usr/bin/chromium-browser --app=https://mail.google.com/mail  

Then you can set the required mailto: handler in Firefox.

Open the Preferences->Applications type mailto -> select action "other" and set the 'mystarter.sh' script.

Next, open gconf-editor and go to /desktop/gnome/applications/url-handlers/mailto and set the command for your chromium webapp

share|improve this answer
    
This looks promising, but I can't get it to work correctly. My webapp is a .desktop file in my home directory. The command to access it is: /usr/bin/chromium-browser --app="mail.google.com/mail";. When I enter this as the new value, I get the error Can't have two slashes '/' in a row –  Tom Brossman Jul 15 '11 at 9:49
    
create a custom script with e.g. name "mystarter.sh" (make it executable) , paste inside it the command for your webapp. And in gconf set the command for "mystarter.sh" –  petrakis Jul 15 '11 at 10:52
    
Also you can set the required mailto handler in Firefox : Open the Preferences->Applications type mailto -> select action "other" and set the script which can run your command (like the solution posted above) –  petrakis Jul 15 '11 at 11:07
    
Many thanks for the replies but I just tried this exactly, and now when I click mailto: links nothing happens at all. The mystarter.sh file is in my home folder, I right-clicked Properties/Permissions and checked the 'Allow executing file as program box, and changed the gconf-editor and Firefox settings as you described. It all went fine except nothing happens now. It's entirely possible this is too complicated for me, I'm not an expert at any of this stuff... –  Tom Brossman Jul 15 '11 at 12:29
    
Tested and working well. Created file mystarter.sh, inside the file #!/bin/bash /usr/bin/chromium-browser --app=https://mail.google.com/mail ,then in firefox assigned for mailto the mystarter.sh. Restart the firefox and is working. IS tested. (the code is two lines, the markdown here is problematic, so it is shebang and after the command) –  petrakis Jul 15 '11 at 12:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.