Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Ubuntu 10.04 on a SATA drive on a desktop computer. It's a 2 TB hitachi. If I go through the standard install process, I get an fsync error. The drive showed up in the installer. When I swapped to the terminal and did an fdisk -l, it showed the other drives, but instead of sda, I got another error message that was also in dmesg:

[  243.128549] end_request: I/O error, dev sda, sector 3907029152
[  243.128648] sd 3:0:0:0: [sda] Unhandled error code
[  243.128652] sd 3:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
[  243.128656] sd 3:0:0:0: [sda] CDB: Read(10): 28 00 e8 e0 87 20 00 00 08 00

dmesg had about 250 copies of those four lines.

I checked this question, and even checked the BIOS settings, but I couldn't find anything helpful, so I turn to the mighty collective wisdom of the SE network. Any ideas about what's wrong? Need more info?


share|improve this question
I suggest you check drive for hardware defects with Hitachi Drive Fitness Test, check cables etc.. Is this a new drive? What was on it before, how was it formatted? What BIOS settings did you try? – Takkat Jul 14 '11 at 6:42
It's a brand new drive. I'm suspecting something rather than the drive, since I have another drive that also had the same error. I'll get the BIOS info up this morning or this evening. – Wayne Werner Jul 14 '11 at 11:36
Might be a bad cable. did you try using a different one? – Thomas Ward Jul 14 '11 at 18:50
DID_BAD_TARGET means there is no such drive. Look for an earlier error that might have led to the drive going away. It should mention ata. – psusi Jul 14 '11 at 19:39
I swapped out the cable, still no dice. Turns out that booting from the USB caused the problems. Currently it's installing from a CD. Any clues why that would be? – Wayne Werner Jul 15 '11 at 1:20
up vote 2 down vote accepted

Apparently the problem was that I was trying to install off of a USB stick. I'm guessing that there was some problem with /dev/sda when the installer booted off of /dev/sdb.

My only guess is that there's some conflict between the serial-ness of the two. I burned a CD (had to use the USB to do that since my other computer has no optical drives!) and it's installing just fine!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.