Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Gnome 3 on the top right corner I have this universal access icon with all these options which I am not intending to use in the meanwhile. How can I disable/hide the useless for me icon there?

share|improve this question
add comment

8 Answers

up vote 15 down vote accepted

Edit the file /usr/share/gnome-shell/js/ui/panel.js

Comment out this line like so:

//'a11y': imports.ui.status.accessibility.ATIndicator,

Full article here.

share|improve this answer
1  
Thank you! The full article is worth a look. –  eisberg Sep 5 '11 at 20:28
1  
worked for me as well..thanks! –  subeh.sharma Jan 11 '12 at 9:16
add comment

There is an extension for that called GNOME Shell noa11y, which removes the Accessibility icon from the GNOME Shell system status area.

more information here.

share|improve this answer
    
That one didn't work for me with gnome shell 3.2.1 –  cweiske Jan 11 '12 at 7:18
add comment

In 3.5 and I believe 3.4 the function was moved to

/usr/share/gnome-shell/js/ui/sessionMode.js

if you comment out line 11

'a11y': imports.ui.status.accessibility.ATIndicator,

it will disable calling the accessibility icon

I also posted a solution at Gnome Shell Remove Accessibility Icon

share|improve this answer
    
I'm on 3.4 and this is indeed the case. Thanks for the tip. Worked for me (after a restart, alt+f2, 'r'). –  Jack Jun 14 '13 at 1:30
add comment

Easy, Click the control Cog at the top right (the one to the right of your name>) Second click System Settings, from there select Universal Access, then select typing and UNSELECT "turn on accessibility features from the keyboard."

The icon should instantly disappear. HOWEVER you may need to reboot.

share|improve this answer
1  
That does not work for me; it only shows/hides an icon in the system tray on the bottom right of the screen. Restarting gnome3 does not help (alt+f2, "r") - the icon stays –  cweiske Jan 11 '12 at 7:07
    
didn't work for me as well –  subeh.sharma Jan 11 '12 at 9:15
add comment

Not a real solution, but notable: There is bug #640190 in the gnome bug tracker which requested this ability. Unfortunately, it has been closed as WONTFIX.

share|improve this answer
add comment

For 3.6 there is no solution at the moment. See https://github.com/ecoleman/noa11y-colemando.com/issues/7

share|improve this answer
add comment

For 3.6 you can remove 'a11y', from line 99 that starts with right:

[ for section 'user': { in /usr/share/gnome-shell/js/ui/sessionMode.js
share|improve this answer
add comment

For GNOME 3.6 there is an extension at https://extensions.gnome.org/extension/112/remove-accesibility/ that solves the problem. It worked for me in Ubuntu 12.10.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.