Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a problem with the Display on my Laptop running Ubuntu 10.04

Since last few days, I am using the laptop in low-graphics mode. When I try to run the command glxinfo, I get a error message

xlib extension glx missing on display !:1.0

and causes a Segmentation Fault.

I am using Toshiba Laptop with 945GM/GMS, 943/940GML Express Integrated Graphics Controller ( Output from lshw )

Note :

I was using Sony Laptop with NVIDIA Graphics card. I took the HDD from Sony Laptop and put it in Toshiba Laptop having Intel Chipset Graphics Card.

Since then, I am having the problem with the display.

I tried to remove the drivers from NVIDIA but with no success.

Please let me know, how to remove the NVIDIA drivers completely and install Intel Drivers.

share|improve this question

migrated from Jul 13 '11 at 19:46

This question came from our site for system and network administrators.

How did you install the NVIDIA drivers in the first place? Did you use the proprietary driver tool in Ubuntu (System->Administration->Drivers -- I think [my Ubuntu boxes aren't here]), or did you download and build the source from NVIDIA? – jwernerny Jul 13 '11 at 20:44
I didnot install NVIDIA Graphics Driver. I installed the drivers with the OS installation (On a Sony Laptop). Now I am using the Old Ubuntu installation from the HDD on a Toshiba Laptop with Intel chipset graphics card. – Jul 13 '11 at 20:53
up vote 2 down vote accepted

Try this

Run sudo dpkg-reconfigure xserver-xorg. This should cause X to reconfigure itself. The appropriate driver (i915) should get automatically chosen.

share|improve this answer
Thanks a Lot.. :) It worked, I installed some applications and removed many from "Ubuntu Software Center". I am not sure, what tricked and what made the Xserver to reconfigure. When I reboot the system, after the many installation and uninstallation, there I had the system, which I always wanted with the xserver properly configured. Thanks again for your time.. – Jul 15 '11 at 9:36

The driver should have an uninstall switch like so:

sudo sh NVIDIA* --uninstall
share|improve this answer
Does this command work ? It doesnt worked me. I got a error message cannot open "sh: Cant open NVIDIA*" Is it possible to uninstall through apt-get remove command ? – Jul 13 '11 at 20:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.