Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm used to this Windows behavior that using CTRL+SHIFT+Cursor Keys I can select text word-wise. CTRL+Cursor Keys jumps word-wise and I use that a lot in combination with SHIFT to select text.

This seems to be a "Windows thing" because it just works in all application. Now turning to Ubuntu 10.04, it doesn't work. CTRL+SHIFT+Cursor Keys just behaves like CTRL+Cursor Keys, i.e. I jump between the words but I can't select them that way.

Another gotcha: I use CTRL+Cursor Keys to move fast between words, press down SHIFT, release CTRL and move the Cursor Keys to select text char by char and it doesn't work either. I need to release both keys complete.

Is there a way to enable this?

share|improve this question
I'm not sure how you're having this problem - Ctrl+Shift+Left/Right cursor jumps text and highlights. What programs are you experiencing this issue in? –  Marco Ceppi Oct 6 '10 at 23:13
In every application I tried. Notably Firefox and Eclipse. Now I'm wondering what's going on here ... –  mark Oct 6 '10 at 23:21
Could you include what your current keyboard layout is? System -> Preferences -> Keyboard –  Marco Ceppi Oct 7 '10 at 0:48
Text selection using Ctrl+Shift+<CursorKey> has always worked for me in Ubuntu. –  Mihai Capotă Oct 7 '10 at 11:21

5 Answers 5

up vote 4 down vote accepted

Found the problem: in Windows I use multiple keyboard layouts and I use CTRL+SHIFT to switch between them. I configured the same for Ubuntu however I'm experiencing a clash here obviously.

That said, Windows is smarty enough to figure out by analyzing which keys I press over time what I want. Ubuntu isn't: once I pressed CTRL+SHIFT, not matter what additional keys, it switched the keyboard layout and for some reason this interrupted the selection option. Too bad.

share|improve this answer

I have the same problem. Discovered that it's 11 years old bug in XOrg.

Here is Ubuntu's bug discussion started in 2006: https://bugs.launchpad.net/xorg-server/+bug/36812

share|improve this answer
Nice contribution, thanks! –  mark Feb 8 '11 at 13:06

I had the same problem in Firefox/Chrome/gEdit. Maddening! This fixed it:

System -> Keyboard Input Methods -> Layouts tab -> Options... -> Misc. compat. options -> Shift w/ numeric keypad keys works as in MS Windows

share|improve this answer

In chrome / firefox, if you select text starting with "control-arrow" to highlight at least one block, then you can "control-shift-arrow" to select by word.

share|improve this answer

To add to the list of causes and workarounds to this problem ...

CTRL+SHIFT+ArrowKeys does not seem to happily select words NumLock is toggled on.

Try turning NumLock off and see what happens.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.