Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can scroll with 2 fingers with my touchpad on Win7 but when I switch to Ubuntu 10.04 it doesn't work, the option is greyed out.

Could anyone help?

  • My touchpad is Synaptics V7.2 PS/2 Port

Can't click

share|improve this question
    
Could you please provide a bit more info? Such as PC Make/Model and the like... –  zkriesse Jul 13 '11 at 15:07
    
What kind of touch pad is it? –  RolandiXor Jul 13 '11 at 15:44
    
@Roland Taylor I don't know where I can look for this info? –  Templar Jul 13 '11 at 15:54
    
On Win7, you can check device info or even the touchpad settings. It will say something like "Synaptics Touchpad blablabla". –  RolandiXor Jul 13 '11 at 16:00
    
I have installed gsynaptics... try it! –  flux Jul 13 '11 at 16:33
show 2 more comments

6 Answers

From Ubuntu forums, you could try something like this.

xinput --set-prop --type=int --format=8  "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 1 1  
share|improve this answer
add comment
up vote 0 down vote accepted

I have tried few solutions but it didn't work however I found out that you can scroll placing one finger to the right of touchpad and going up or down. enter image description here

share|improve this answer
add comment

I had the same problem when I was using 10.04. Basically I think there is a bug which doesnot show two finger scrolling option although it works in older package. I think you can enable the graphical button from gconf but it didnot help me then. Here are some questions I posted with some solutions:

Touchpad two finger sensivity problem

Vostro 3400 touchpad multiple gesture and two finger scrolling not working

Two finger scrolling not working

share|improve this answer
add comment

If my previous answer didn't work for any reason it means there is a compatibility issue with the touchpad, to fix it you need to enable SHMConfig, to do it type in the terminal:

gksudo gedit /etc/X11/xorg.conf, in the file that will open add it:

Section "InputClass"
    Identifier "enable synaptics SHMConfig"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Option "SHMConfig" "on"
EndSection

If there is a Section "ServerLayout" in the file, add this line into it:

InputDevice     "SynapticsMouse1" "AlwaysCore"

Save the file, close it and reboot your system.

Then install these packages from the Universe Repository:

  • gsynaptics
  • synclient
  • xserver-xorg-input-synaptics

After a reboot try enabling Two-finger scrolling through Mouse Preferences and if it's still impossible try in the terminal:

synclient -l , that will list every touchpad settings possible, then try some settings with this structure: setting=1 to enable and setting=0 to disable.

Eventually, if you didn't achieve nothing, see this Touchpad Troubleshooting Page and if any, report a bug.

share|improve this answer
add comment

Try adding

synclient VertTwoFingerScroll=1
synclient HorizTwoFingerScroll=1
synclient EmulateTwoFingerMinW=5
synclient EmulateTwoFingerMinZ=48

to the end of your ~/.bashrc file and reboot (loging out and in again should also work).

share|improve this answer
add comment

In Ubuntu this option is disabled by default, go to System > Preferences > Mouse, in the Touchpad tab select "Two-finger scrolling" and that's done. Select Two-finger scrolling

share|improve this answer
    
I can't click on it i.stack.imgur.com/oUP7Q.png –  Templar Jul 14 '11 at 9:29
    
Oh! I see your problem, it's because you're using Ubuntu 10.04 and this version still has some incompatibility issues with touchpads. I will look for a solution. –  Rodrigo Martins Jul 14 '11 at 13:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.