Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Eclipse for java development. My work space is in sda1 drive. Every time login need to Mount the drive after only I can use that work space under sda1 drive. For this I installed Storage Device Manager(pysdm). after Installed it eclipse cant use the drive as workspace. So that I Uninstalled pysdm. even that problem exist. I can do for this issue? Need your intelligence Idea to solve this prob.

UPDATE 22/11/11

Removed Pysdm and instead used fstab to automount external disk with correct permissions. Appears to have succeeded in using blkid to create proper fstab entry but still cannot access the new volume.


User4124. as you asked I'm posting cat /etc/fstab Details. (Adding it as answer here bze can't add comment more letters)

silambarasan@silambarasan-PC:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc        proc  nodev,noexec,nosuid  0  0  
/dev/sda8                                  /            ext2  errors=remount-ro    0  1  
# swap was on /dev/sda7 during installation
UUID=81edad8d-06a4-42f4-a485-9ef293b9c0fa  none         swap  sw                   0  0  
/dev/sda1                                  /media/sda1  vfat  defaults             0  0  
/dev/sda5                                  /media/sda5  vfat  defaults             0  0  
/dev/sda6                                  /media/sda6  vfat  defaults             0  0  
silambarasan@silambarasan-PC:~$ 
share|improve this question

closed as too localized by Marco Ceppi Jan 13 '12 at 13:22

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You have many good answers in the past - please go through them and accept them. Not doing so, discourages people from answering your questions. –  fossfreedom Jul 16 '11 at 18:29
    
This question appears abandoned by the user. If you have this same issue, or a similar one, please open a new question. –  Marco Ceppi Jan 13 '12 at 13:22

1 Answer 1

Most probably the default mount options for /dev/sda1 do not permit access as a normal user. Either that, or you need to change the owner of the files for the /dev/sda1 partition. You can change the ownership of the files with sudo nautilus, then navigate to the workspace files and change the owner. Finally, close the nautilus window.

Can you post the contents of /etc/fstab? It should show the current mount options.

share|improve this answer
    
I'm getting following msg when run the command: silambarasan@silambarasan-PC:/$ etc/fstab bash: etc/fstab: Permission denied silambarasan@silambarasan-PC:/$ –  Silambarasan Jul 15 '11 at 16:44
    
And also I tried sudo nautilus, root folder window opened. I tried to Modify owner of drive but I got Following pop up Msg came: The Owner Could not be changed Sorry,could not change the owner of "sda1": Error Setting owner:Operation not permitted –  Silambarasan Jul 15 '11 at 16:55
    
To get the contents of /etc/fstab, run cat /etc/fstab. –  user4124 Jul 15 '11 at 19:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.