Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I made a confusion with some informations and I thought that I have a Realtek audio card, but in really I have an Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller, so when I installed the Realtek High Definition Audio Codecs it made a mess with the sound-related files, resuming, in the driver's readme it says that by default it mutes every audio channel and you is supposed to use some ALSA or OSS mixer to unmute them, and was in this part I noticed I made this confusion, because I got this trying to unmute the channels:

sudo alsamixer returns: cannot open the mixer: No such file or directory

sudo amixer returns: amixer: Mixer attach default error: No such file or directory

I already reinstalled every alsa realated package and got nothing, changing Sound Preferences settings doesn't work and there isn't any instructions to how to uninstall the Realtek drivers. I know the Realtek drivers changed something related to "sdn" and "hda".

So, how can I fix this problem?

share|improve this question

closed as off topic by James May 22 '12 at 18:41

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Can someone answer? – Rodrigo Martins Jul 16 '11 at 17:51
I 've got the very same trouble, after compiling and installing the HDA driver from I definitely lost my sound system. lspci still lists my audio chip which is however not Realtek, aplay -l tells there are no audio cards found. Complete reinstall of all alsa stuff no help. Any working solution is highly appreciated. – user21922 Jul 20 '11 at 14:04
if someone has an answer they'll post. Patience is a virtue on this site - sometimes the answer doesnt come around very fast (and sometimes ends up coming weeks later) – Thomas Ward Jul 20 '11 at 14:08
After all this time, I voted to close this question. If it is not working you should file a bug report. – bodhi.zazen Feb 26 '12 at 3:57

This is from a post by lidex on Ubuntu forums

Using a Terminal="Applications->Accessories->Terminal"

sudo aptitude --purge reinstall linux-sound-base alsa-base alsa-utils linux-image-`uname -r` linux-ubuntu-modules-`uname -r` libasound2


For a 'command not found' error simply install aptitude:

sudo apt-get install aptitude
share|improve this answer

The Realtek drivers sort of worked for me; it might just be that the ALSA mixer is muted after the driver installation. I have also encountered a funny problem in that on my laptop I think the soundcard can somehow be muted in hardware (there's a keyboard short-cut to toggle it.)

I had a go at using the Realtek drivers but ended up reinstalling the previous version of the kernel that I knew worked from the liveCD using chroot (a far from ideal situation to be in).

That's not to say that the Realtek drivers can't be made to work but I found them to be more hassle than they're worth.

Update: I have another issues with my sound now possibly based around competition between my soundcard and graphic card but I believe this to be unconnected as there is sound sometimes.

share|improve this answer

With this link I take back my audio twice, ... after that, I gave up try to install realteak drivers. =(

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` linux-alsa-driver-modules-$(uname -r) libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` linux-alsa-driver-modules-$(uname -r)  libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.