Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently, my Ubuntu Natty system has started to log me into Ubuntu Classic (i.e. GNOME desktop) instead of Unity the first time I log in after a reboot. I have made sure to select "Unity" from the session menu before logging in. Every subsequent login works fine until the next reboot.

What is causing this, and how do I fix it?

share|improve this question
add comment

closed as too localized by Ryan Thompson, RolandiXor, Mitch, con-f-use, Jorge Castro Aug 28 '12 at 14:20

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

Maybe there has been some change in the video configuration or the graphics card driver has been updated, unity doesn't support that change/update and, consequently, it falls to classic desktop.

Anyway, I'd take a look at /var/log to verify if some problem regarding unity has been logged.

share|improve this answer
add comment

Did you change the default in your login screen settings? I.E. System -> Administration -> Login Screen I don't see why that would have a solid effect because it's almost the same thing as the actual login screen settings you do when logging in but you never know.

share|improve this answer
    
Yes, the default session is set to "Ubuntu". –  Ryan Thompson Jul 13 '11 at 2:26
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.