Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

from a couple of days I'm having a problem with Gnome3 gnome-shell. When I reboot / power-on the machine, after the GDM login the DE is stuck without opening gnome-shell. If I restart gdm from another tty, then everything works (GDM restarts and gnome-shell appears). So it hangs only the first time i login.

I was looking for more information on what is happening, but I can't find a gdm or gnome-shell detailed log. any suggestions?

Currently using Gnome3 PPA + (ricotz PPA) + ATI open source drivers

share|improve this question
I thought that the Ricotz GNOME 3 PPA had stopped being updated way back during GNOME 3's development? Or did something about that change and I didn't notice since I was just compiling everything from GNOME's git repos? – Christopher Kyle Horton Jul 13 '11 at 4:28
Actually it's up-to-date and is the only one with the latest gnome-shell package. – Juan Sebastian Totero Jul 13 '11 at 5:37
And why are you using both the Gnome 3 team PPA and the ricotz PPA?, shouldn't you be using only one? – Uri Herrera Jul 13 '11 at 6:33
Gnome3ppa gives me "quite stable" packages, and riotz gives me the latest gnome-shell and network-manager. – Juan Sebastian Totero Jul 13 '11 at 11:08
Anyway, they are compatible, and gnome3ppa is required by ricotz, as you can see in his launchpad dedicated page. – Juan Sebastian Totero Jul 13 '11 at 11:15
up vote 1 down vote accepted

I did have the same problem in natty with Unity not booting in but after I took the plunge and installed the ATI fglrx drivers the problem disappeared completly. Not sure if that would help you with gnome 3 but it might be worth a try

I did it using the terminal with the

sudo apt-get install fglrx

For some reason I do not understand it fixed my login issues issues and I was having exactly the same issue as you ie I would have to log in again to get a desktop which was (as you are finding ) a little annoying.

I would have preferred to stick with the open source drivers and do not do any 3d stuff to speak of but as this fix worked for me I stuck with it.

Let us know how you get on.

share|improve this answer
GNOME3 is not compatible with fglrx in my installation, I had to remove it to make GNOME3 work.... but your answer helped me solving the problem. Actually, I had installed fglrx on the machine, later uninstalled it and switched to open-source drivers. For some reason, X was still trying to load fglrx module and reported the MISS in Xorg.conf. sudo update-alternatives --config gl_conf and setting to Auto solved the problem and now gnome-shell is working perfectly, without login issues. – Juan Sebastian Totero Jul 13 '11 at 11:11
yippee! :) Might be worth checking here to make sure fglrx is completely purged.… – andybleaden Jul 13 '11 at 12:53
this is a good link too :) – Juan Sebastian Totero Jul 13 '11 at 15:12
hmm...not seen that one.will now have a read and learn more...cheers :) I did try gnome shell etc when it was a seperate ppa for 11.04. It crashed and had to reinstall most of unity which was a pain but I have heard it works fine it good? – andybleaden Jul 13 '11 at 15:45
Actually it's working very well :) Personally I prefer gnome-shell to unity but it's a matter of personal taste – Juan Sebastian Totero Jul 13 '11 at 17:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.